aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2016-09-08 09:42:43 +0800
committerwen <wen@FreeBSD.org>2016-09-08 09:42:43 +0800
commitef202d1177c74fe999d48e40899b2b60ad7d761b (patch)
tree8305d58ee0c202968146aa4982b7f63486c2c3d1
parentb5706830aac8cb9ae63483a446fb54d6b1dcf525 (diff)
downloadfreebsd-ports-gnome-ef202d1177c74fe999d48e40899b2b60ad7d761b.tar.gz
freebsd-ports-gnome-ef202d1177c74fe999d48e40899b2b60ad7d761b.tar.zst
freebsd-ports-gnome-ef202d1177c74fe999d48e40899b2b60ad7d761b.zip
- Repocopy py-django19 --> py-django110 and update to 1.10.1
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django110/Makefile68
-rw-r--r--www/py-django110/distinfo3
-rw-r--r--www/py-django110/pkg-descr10
4 files changed, 82 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ff0aa43b96c1..ab9383f35936 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1582,6 +1582,7 @@
SUBDIR += py-django-threaded-multihost
SUBDIR += py-django-tinymce
SUBDIR += py-django-voting
+ SUBDIR += py-django110
SUBDIR += py-django16
SUBDIR += py-django16-tastypie
SUBDIR += py-django18
diff --git a/www/py-django110/Makefile b/www/py-django110/Makefile
new file mode 100644
index 000000000000..ad42f4af2682
--- /dev/null
+++ b/www/py-django110/Makefile
@@ -0,0 +1,68 @@
+# Created by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+# $FreeBSD$
+
+PORTNAME= django
+PORTVERSION= 1.10.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP \
+ https://www.djangoproject.com/m/releases/${PORTVERSION}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 110
+DISTNAME= Django-${PORTVERSION}
+DIST_SUBDIR= python
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= High-level Python Web Framework
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cpe python
+USE_PYTHON= autoplist distutils
+
+CONFLICTS_INSTALL= py??-django-devel-* py??-django1[689]-*
+CPE_VENDOR= djangoproject
+
+DOCSDIR= ${PREFIX}/share/doc/py-django
+
+OPTIONS_DEFINE= FASTCGI HTMLDOCS
+OPTIONS_DEFAULT= SQLITE
+
+OPTIONS_GROUP= DATABASE
+OPTIONS_GROUP_DATABASE= PGSQL MYSQL SQLITE
+
+HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
+
+PLIST_FILES= man/man1/django-admin.1.gz
+
+PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+FASTCGI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flup>0:www/py-flup
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MHTMLDOCS}
+. if empty(PORT_OPTIONS:MDOCS)
+IGNORE= you cannot build documentation with DOCS option disabled
+. endif
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx
+PORTDOCS= *
+.endif
+
+post-build:
+.if ${PORT_OPTIONS:MHTMLDOCS}
+ cd ${WRKSRC}/docs && ${MAKE} html
+.endif
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${MAN1PREFIX}/man/man1
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
+ @${ECHO_MSG} ""
+.if ${PORT_OPTIONS:MHTMLDOCS}
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/_build/html ${STAGEDIR}/${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/py-django110/distinfo b/www/py-django110/distinfo
new file mode 100644
index 000000000000..09cd5b9ecad8
--- /dev/null
+++ b/www/py-django110/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1473148535
+SHA256 (python/Django-1.10.1.tar.gz) = d6e6c5b25cb67f46afd7c82f536529b11981183423dad8932e15bce93d1a24f3
+SIZE (python/Django-1.10.1.tar.gz) = 7700057
diff --git a/www/py-django110/pkg-descr b/www/py-django110/pkg-descr
new file mode 100644
index 000000000000..638401f81c0e
--- /dev/null
+++ b/www/py-django110/pkg-descr
@@ -0,0 +1,10 @@
+Django is a high-level Python Web framework that encourages rapid development
+and clean, pragmatic design.
+
+Developed and used over the past two years by a fast-moving online-news
+operation, Django was designed from scratch to handle two challenges: the
+intensive deadlines of a newsroom and the stringent requirements of experienced
+Web developers. It has convenient niceties for developing content-management
+systems, but it's an excellent tool for building any Web site.
+
+WWW: http://www.djangoproject.com