aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-02-15 01:02:11 +0800
committeryuri <yuri@FreeBSD.org>2018-02-15 01:02:11 +0800
commitf177c10d8424851b235d4273e18ac940a94e5d73 (patch)
tree1fb30537c1828d01ab9e335ad903e361bf833ee4
parentde1909e28408a0c9bbbb219e6ee7af97cb8b3ada (diff)
downloadfreebsd-ports-gnome-f177c10d8424851b235d4273e18ac940a94e5d73.tar.gz
freebsd-ports-gnome-f177c10d8424851b235d4273e18ac940a94e5d73.tar.zst
freebsd-ports-gnome-f177c10d8424851b235d4273e18ac940a94e5d73.zip
devel/easyloggingpp: Update to 9.96.0
Changelog: https://github.com/muflihun/easyloggingpp/releases/tag/v9.96.0 Reported by: portscout Approved by: tcberner (mentor, implicit)
-rw-r--r--devel/easyloggingpp/Makefile5
-rw-r--r--devel/easyloggingpp/distinfo6
-rw-r--r--devel/easyloggingpp/files/patch-CMakeLists.txt17
3 files changed, 19 insertions, 9 deletions
diff --git a/devel/easyloggingpp/Makefile b/devel/easyloggingpp/Makefile
index bd416e3b1af5..1b42fe0afa73 100644
--- a/devel/easyloggingpp/Makefile
+++ b/devel/easyloggingpp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= easyloggingpp
DISTVERSIONPREFIX= v
-DISTVERSION= 9.95.4
+DISTVERSION= 9.96.0
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -19,6 +19,7 @@ CMAKE_ON= build_shared_lib # patched in, requested such option in https://githu
PLIST_FILES= include/easylogging++.h \
include/easylogging++.cc \
- lib/libeasyloggingpp.so
+ lib/libeasyloggingpp.so \
+ libdata/pkgconfig/easyloggingpp.pc
.include <bsd.port.mk>
diff --git a/devel/easyloggingpp/distinfo b/devel/easyloggingpp/distinfo
index 30bab40f512b..cf8ea31ab026 100644
--- a/devel/easyloggingpp/distinfo
+++ b/devel/easyloggingpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518262857
-SHA256 (muflihun-easyloggingpp-v9.95.4_GH0.tar.gz) = 1d1814db8f95f40b37e92b4c18c1630766c285012f6716cb08e29116fd526059
-SIZE (muflihun-easyloggingpp-v9.95.4_GH0.tar.gz) = 747571
+TIMESTAMP = 1518627108
+SHA256 (muflihun-easyloggingpp-v9.96.0_GH0.tar.gz) = be81a58d9a75986ea06432e0ee9859dd67fb0d8976265fc69a2f6299498fa6f9
+SIZE (muflihun-easyloggingpp-v9.96.0_GH0.tar.gz) = 748440
diff --git a/devel/easyloggingpp/files/patch-CMakeLists.txt b/devel/easyloggingpp/files/patch-CMakeLists.txt
index b309f7cdf59a..1a7f829e0cef 100644
--- a/devel/easyloggingpp/files/patch-CMakeLists.txt
+++ b/devel/easyloggingpp/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
Suggested the same to the upstream: https://github.com/muflihun/easyloggingpp/issues/603
---- CMakeLists.txt.orig 2017-10-13 00:35:14 UTC
+--- CMakeLists.txt.orig 2018-02-14 05:35:11 UTC
+++ CMakeLists.txt
@@ -22,7 +22,7 @@ macro(require_cpp11)
endmacro()
@@ -11,9 +11,18 @@ Suggested the same to the upstream: https://github.com/muflihun/easyloggingpp/is
option(lib_utc_datetime "Build library with UTC date/time logging" OFF)
set(ELPP_MAJOR_VERSION "9")
-@@ -40,17 +40,17 @@ install(FILES
- DESTINATION "${ELPP_INCLUDE_INSTALL_DIR}"
- COMPONENT dev)
+@@ -31,7 +31,7 @@ set(ELPP_PATCH_VERSION "0")
+ set(ELPP_VERSION_STRING "${ELPP_MAJOR_VERSION}.${ELPP_MINOR_VERSION}.${ELPP_PATCH_VERSION}")
+
+ set(ELPP_INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include" CACHE PATH "The directory the headers are installed in")
+-set(ELPP_PKGCONFIG_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/share/pkgconfig" CACHE PATH "Installation directory for pkgconfig (.pc) files")
++set(ELPP_PKGCONFIG_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig" CACHE PATH "Installation directory for pkgconfig (.pc) files")
+
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+
+@@ -46,17 +46,17 @@ configure_file( ${CMAKE_CURRENT_SOURCE_D
+
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/easyloggingpp.pc DESTINATION "${ELPP_PKGCONFIG_INSTALL_DIR}")
-if (build_static_lib)
+if (build_shared_lib)