aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-04-24 00:53:36 +0800
committermat <mat@FreeBSD.org>2018-04-24 00:53:36 +0800
commitf1feaf13e921e3a40ed75d06339b9b78a49ec290 (patch)
treedde8eead8998661188185912f690a6429e484463
parentd5b28f32a3ae1cb4f4f5453f36269068e1181caf (diff)
downloadfreebsd-ports-gnome-f1feaf13e921e3a40ed75d06339b9b78a49ec290.tar.gz
freebsd-ports-gnome-f1feaf13e921e3a40ed75d06339b9b78a49ec290.tar.zst
freebsd-ports-gnome-f1feaf13e921e3a40ed75d06339b9b78a49ec290.zip
Update to 2018.3.0
PR: 227721 Submitted by: maintainer Sponsored by: Absolight
-rw-r--r--sysutils/py-salt/Makefile3
-rw-r--r--sysutils/py-salt/distinfo6
-rw-r--r--sysutils/py-salt/files/patch-salt_modules_freebsdservice.py18
-rw-r--r--sysutils/py-salt/files/patch-salt_modules_pkgng.py92
-rw-r--r--sysutils/py-salt/files/patch-setup.py4
5 files changed, 6 insertions, 117 deletions
diff --git a/sysutils/py-salt/Makefile b/sysutils/py-salt/Makefile
index b41d7ad294dd..cfbaed8d66b5 100644
--- a/sysutils/py-salt/Makefile
+++ b/sysutils/py-salt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= salt
-PORTVERSION= 2017.7.4
-PORTREVISION= 3
+PORTVERSION= 2018.3.0
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/sysutils/py-salt/distinfo b/sysutils/py-salt/distinfo
index 15714adcba29..a822a67f69cc 100644
--- a/sysutils/py-salt/distinfo
+++ b/sysutils/py-salt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520059286
-SHA256 (salt-2017.7.4.tar.gz) = 1d573095776ba052eec7d7cae1472f4b1d4c15f16e1d79c2dc48db3129dbae97
-SIZE (salt-2017.7.4.tar.gz) = 11718327
+TIMESTAMP = 1523675641
+SHA256 (salt-2018.3.0.tar.gz) = a0a45d22fdf6961542a419b7e09568a3118e2b019ffe7bab9dee5aeb55b56b31
+SIZE (salt-2018.3.0.tar.gz) = 13448567
diff --git a/sysutils/py-salt/files/patch-salt_modules_freebsdservice.py b/sysutils/py-salt/files/patch-salt_modules_freebsdservice.py
deleted file mode 100644
index d6a019a3c598..000000000000
--- a/sysutils/py-salt/files/patch-salt_modules_freebsdservice.py
+++ /dev/null
@@ -1,18 +0,0 @@
---- salt/modules/freebsdservice.py.orig 2017-08-15 15:26:36 UTC
-+++ salt/modules/freebsdservice.py
-@@ -16,7 +16,6 @@ import os
-
- # Import salt libs
- import salt.utils
--import salt.utils.decorators as decorators
- from salt.exceptions import CommandNotFoundError
-
- __func_alias__ = {
-@@ -39,7 +38,6 @@ def __virtual__():
- return (False, 'The freebsdservice execution module cannot be loaded: only available on FreeBSD systems.')
-
-
--@decorators.memoize
- def _cmd(jail=None):
- '''
- Return full path to service command
diff --git a/sysutils/py-salt/files/patch-salt_modules_pkgng.py b/sysutils/py-salt/files/patch-salt_modules_pkgng.py
deleted file mode 100644
index 84015e2ea480..000000000000
--- a/sysutils/py-salt/files/patch-salt_modules_pkgng.py
+++ /dev/null
@@ -1,92 +0,0 @@
---- salt/modules/pkgng.py.orig 2017-10-09 16:37:42 UTC
-+++ salt/modules/pkgng.py
-@@ -1154,8 +1154,6 @@ def upgrade(*names, **kwargs):
- opts += 'n'
- if not dryrun:
- opts += 'y'
-- if opts:
-- opts = '-' + opts
-
- cmd = _pkg(jail, chroot, root)
- cmd.append('upgrade')
-@@ -1181,7 +1179,11 @@ def upgrade(*names, **kwargs):
- return ret
-
-
--def clean(jail=None, chroot=None, root=None):
-+def clean(jail=None,
-+ chroot=None,
-+ root=None,
-+ clean_all=False,
-+ dryrun=False):
- '''
- Cleans the local cache of fetched remote packages
-
-@@ -1190,11 +1192,64 @@ def clean(jail=None, chroot=None, root=None):
- .. code-block:: bash
-
- salt '*' pkg.clean
-- salt '*' pkg.clean jail=<jail name or id>
-- salt '*' pkg.clean chroot=/path/to/chroot
-+
-+ jail
-+ Cleans the package cache in the specified jail
-+
-+ CLI Example:
-+
-+ .. code-block:: bash
-+
-+ salt '*' pkg.clean jail=<jail name or id>
-+
-+ chroot
-+ Cleans the package cache in the specified chroot (ignored if ``jail``
-+ is specified)
-+
-+ root
-+ Cleans the package cache in the specified root (ignored if ``jail``
-+ is specified)
-+
-+ CLI Example:
-+
-+ .. code-block:: bash
-+
-+ salt '*' pkg.clean chroot=/path/to/chroot
-+
-+ clean_all
-+ Clean all packages from the local cache (not just those that have been
-+ superseded by newer versions).
-+
-+ CLI Example:
-+
-+ .. code-block:: bash
-+
-+ salt '*' pkg.clean clean_all=True
-+
-+ dryrun
-+ Dry-run mode. This list of changes to the local cache is always
-+ printed, but no changes are actually made.
-+
-+ CLI Example:
-+
-+ .. code-block:: bash
-+
-+ salt '*' pkg.clean dryrun=True
- '''
-+ opts = ''
-+ if clean_all:
-+ opts += 'a'
-+ if dryrun:
-+ opts += 'n'
-+ else:
-+ opts += 'y'
-+
-+ cmd = _pkg(jail, chroot, root)
-+ cmd.append('clean')
-+ if opts:
-+ cmd.append('-' + opts)
- return __salt__['cmd.run'](
-- _pkg(jail, chroot, root) + ['clean'],
-+ cmd,
- output_loglevel='trace',
- python_shell=False
- )
diff --git a/sysutils/py-salt/files/patch-setup.py b/sysutils/py-salt/files/patch-setup.py
index 616ec5cf0778..e1516c3225de 100644
--- a/sysutils/py-salt/files/patch-setup.py
+++ b/sysutils/py-salt/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2016-11-22 16:50:54 UTC
+--- setup.py.orig 2018-04-02 16:35:13 UTC
+++ setup.py
-@@ -988,8 +988,8 @@ class SaltDistribution(distutils.dist.Di
+@@ -992,8 +992,8 @@ class SaltDistribution(distutils.dist.Di
def _property_data_files(self):
# Data files common to all scenarios
data_files = [