aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2018-10-17 14:23:59 +0800
committerkoobs <koobs@FreeBSD.org>2018-10-17 14:23:59 +0800
commitf4919299c8e37dfe45e7ba73162ec78b653ae3ef (patch)
tree5e7aa5bdcadd2b453744c08a44f6404cb463f486
parent8c3e4e411d6b7cf9c3a2d157aea7a8741118b694 (diff)
downloadfreebsd-ports-gnome-f4919299c8e37dfe45e7ba73162ec78b653ae3ef.tar.gz
freebsd-ports-gnome-f4919299c8e37dfe45e7ba73162ec78b653ae3ef.tar.zst
freebsd-ports-gnome-f4919299c8e37dfe45e7ba73162ec78b653ae3ef.zip
lang/python27,35+: Remove MAKE_JOBS_UNSAFE
ports r393217 via bug 200622 [1] originally set MAKE_JOBS_UNSAFE=yes due to incorrect uses of recursive make [2], causing intermittent build failures when run with multiple jobs (-jN). Upstream committed a fix for the issue in default (3.6, at the time), 3.5 and 2.7 which are now contained in all released lang/python?? port versions. 3.4 did not receieve a backport merge. lang/python3.5+ ports inadvertently inherited MAKE_JOBS_UNSAFE=yes, via repocopies from lang/python34 on their creation, when they were infact safe to use with -j. Remove MAKE_JOBS_UNSAFE in all lang/python?? ports except python34 accordingly. [1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=200622 [2] https://bugs.python.org/issue22359 PR: 232308 Reported by: cem Reviewed by: cem Approved by: koobs (python) MFH: 2018Q4 Differential Revision: D17579
-rw-r--r--lang/python27/Makefile1
-rw-r--r--lang/python35/Makefile1
-rw-r--r--lang/python36/Makefile1
-rw-r--r--lang/python37/Makefile1
4 files changed, 0 insertions, 4 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index d6b0d0bf5a82..77f7c361b7cd 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -34,7 +34,6 @@ TEST_TARGET= buildbottest
TEST_ARGS= TESTOPTS=-j${MAKE_JOBS_NUMBER}
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
-MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
PLIST_SUB= ABI=${ABIFLAGS} \
PORTVERSION=${PORTVERSION} \
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index 09c7dd017c80..2fbbe445e0fc 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -37,7 +37,6 @@ TEST_TARGET= buildbottest
TEST_ARGS= TESTOPTS=-j${MAKE_JOBS_NUMBER}
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
-MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
SUB_FILES= pkg-message
SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 024ddd3e2834..ed05b81faced 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -37,7 +37,6 @@ TEST_TARGET= buildbottest
TEST_ARGS= TESTOPTS=-j${MAKE_JOBS_NUMBER}
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
-MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
SUB_FILES= pkg-message
SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index 1bbbaa4ae7ca..15ed7b2381a6 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -37,7 +37,6 @@ TEST_TARGET= buildbottest
TEST_ARGS= TESTOPTS=-j${MAKE_JOBS_NUMBER}
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
-MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
SUB_FILES= pkg-message
SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}