aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-11-29 22:14:02 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-11-29 22:14:02 +0800
commitf795e9dbd924f16a67133359d53ec461349034c7 (patch)
tree764e8a210aba40078c375a53c3ddfbc47ecfb6a5
parente430bdd22c68eb5381719579b9a2a5cd72ad9a2b (diff)
downloadfreebsd-ports-gnome-f795e9dbd924f16a67133359d53ec461349034c7.tar.gz
freebsd-ports-gnome-f795e9dbd924f16a67133359d53ec461349034c7.tar.zst
freebsd-ports-gnome-f795e9dbd924f16a67133359d53ec461349034c7.zip
Add p5-HTML-Chuncks, a simple nested template engine for HTML, XML and XHTML
PR: 89631 Submitted by: Alexander Koch <fbsd@meersau.de>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Chuncks/Makefile33
-rw-r--r--www/p5-HTML-Chuncks/distinfo3
-rw-r--r--www/p5-HTML-Chuncks/pkg-descr4
-rw-r--r--www/p5-HTML-Chuncks/pkg-plist9
5 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 087348ef0057..8c6e382ed424 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -522,6 +522,7 @@
SUBDIR += p5-HTML
SUBDIR += p5-HTML-Breadcrumbs
SUBDIR += p5-HTML-CalendarMonthSimple
+ SUBDIR += p5-HTML-Chuncks
SUBDIR += p5-HTML-Clean
SUBDIR += p5-HTML-Diff
SUBDIR += p5-HTML-Element-Extended
diff --git a/www/p5-HTML-Chuncks/Makefile b/www/p5-HTML-Chuncks/Makefile
new file mode 100644
index 000000000000..1b1a5bb79876
--- /dev/null
+++ b/www/p5-HTML-Chuncks/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-HTML-Chunks
+# Date created: 27 November 2005
+# Whom: Alexander Koch <fbsd@meersau.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Chunks
+PORTVERSION= 1.53
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fbsd@meersau.de
+COMMENT= A simple nested template engine for HTML, XML and XHTML
+
+RUN_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy
+
+PERL_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN3= HTML::Chunks.3 HTML::Chunks::Local.3 HTML::Chunks::Super.3 \
+ HTML::ChunksLocal.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500806
+IGNORE= needs Perl 5.8.6 or above (lang/perl5.8)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-Chuncks/distinfo b/www/p5-HTML-Chuncks/distinfo
new file mode 100644
index 000000000000..4898c81e948c
--- /dev/null
+++ b/www/p5-HTML-Chuncks/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Chunks-1.53.tar.gz) = 2504a5e89b52e81c9504fd78484c5e18
+SHA256 (HTML-Chunks-1.53.tar.gz) = e0d431eede9c14d7df804d89005923df3c682fb16190ae85d27ed1d876ac9eff
+SIZE (HTML-Chunks-1.53.tar.gz) = 10570
diff --git a/www/p5-HTML-Chuncks/pkg-descr b/www/p5-HTML-Chuncks/pkg-descr
new file mode 100644
index 000000000000..be7e8a84ea46
--- /dev/null
+++ b/www/p5-HTML-Chuncks/pkg-descr
@@ -0,0 +1,4 @@
+HTML::Chunks is a Perl module which provides a simple template system for HTML,
+XML and XHTML.
+
+WWW: http://search.cpan.org/dist/HTML-Chunks/
diff --git a/www/p5-HTML-Chuncks/pkg-plist b/www/p5-HTML-Chuncks/pkg-plist
new file mode 100644
index 000000000000..3652b5ea1f91
--- /dev/null
+++ b/www/p5-HTML-Chuncks/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/HTML/Chunks.pm
+%%SITE_PERL%%/HTML/Chunks/Local.pm
+%%SITE_PERL%%/HTML/Chunks/Super.pm
+%%SITE_PERL%%/HTML/ChunksLocal.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Chunks/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Chunks
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@dirrm %%SITE_PERL%%/HTML/Chunks
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true