aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-01 20:25:46 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-01 20:25:46 +0800
commitf87d1398d4101c11fd72387554301327a8226e48 (patch)
tree9ffcf47466cf6bf8528134ba0aad263bc9a67220
parent5c9d3a3305fdbacb34dc6db583b10ec2e7148210 (diff)
downloadfreebsd-ports-gnome-f87d1398d4101c11fd72387554301327a8226e48.tar.gz
freebsd-ports-gnome-f87d1398d4101c11fd72387554301327a8226e48.tar.zst
freebsd-ports-gnome-f87d1398d4101c11fd72387554301327a8226e48.zip
games/xmemory: unbreak with libc++ 3.9
gif_image.C:61:7: error: assigning to 'char *' from incompatible type 'const char *' name = strrchr(filename,'/'); ^ ~~~~~~~~~~~~~~~~~~~~~ Reported by: pkg-fallout
-rw-r--r--games/xmemory/Makefile2
-rw-r--r--games/xmemory/files/patch-gif__image.C13
2 files changed, 14 insertions, 1 deletions
diff --git a/games/xmemory/Makefile b/games/xmemory/Makefile
index 9c361c139096..7d19789fcc05 100644
--- a/games/xmemory/Makefile
+++ b/games/xmemory/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmemory
PORTVERSION= 3.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= XCONTRIB/games/multiplayer
diff --git a/games/xmemory/files/patch-gif__image.C b/games/xmemory/files/patch-gif__image.C
new file mode 100644
index 000000000000..ac3b3026e31d
--- /dev/null
+++ b/games/xmemory/files/patch-gif__image.C
@@ -0,0 +1,13 @@
+--- gif_image.C.orig 1996-07-04 20:36:15 UTC
++++ gif_image.C
+@@ -58,8 +58,8 @@ GifImage::GifImage(const char *filename,
+ : lockcount(0) {
+ first=0;
+ LoadGIF( filename );
+- name = strrchr(filename,'/');
+- if (name) name=strdup(name+1);
++ const char *pos = strrchr(filename,'/');
++ if (pos) name=strdup(pos+1);
+ else name=strdup(filename);
+
+ if (autocrop&&!fastinfo_flag) CropImage();