aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2009-03-15 02:29:23 +0800
committerlippe <lippe@FreeBSD.org>2009-03-15 02:29:23 +0800
commitfa40a4901c0bb152098590c38085c9f2fdf3f830 (patch)
treefd6648f9a57445717a26723603413ffdd72788ec
parentc0c6b2c6fbbc5e8dd50505b4e8bc57eeb20ebd0c (diff)
downloadfreebsd-ports-gnome-fa40a4901c0bb152098590c38085c9f2fdf3f830.tar.gz
freebsd-ports-gnome-fa40a4901c0bb152098590c38085c9f2fdf3f830.tar.zst
freebsd-ports-gnome-fa40a4901c0bb152098590c38085c9f2fdf3f830.zip
Exuberant Ctags supports indexing of many modern programming languages. Python
is a powerful scriptable dynamic language. Using Python to access Ctags index file is a natural fit in extending an application's capability to examine source code. WWW: http://www.python.org/pypi/python-ctags/ PR: ports/131983 Submitted by: Aaron Diep <ahkdiep@gmail.com> Reviewed by: myself
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ctags/Makefile23
-rw-r--r--devel/py-ctags/distinfo3
-rw-r--r--devel/py-ctags/pkg-descr12
-rw-r--r--devel/py-ctags/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ed750b7c8a69..188099bceb88 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2220,6 +2220,7 @@
SUBDIR += py-cmdln
SUBDIR += py-cog
SUBDIR += py-configobj
+ SUBDIR += py-ctags
SUBDIR += py-ctypes
SUBDIR += py-cxx
SUBDIR += py-dal
diff --git a/devel/py-ctags/Makefile b/devel/py-ctags/Makefile
new file mode 100644
index 000000000000..33522dd78fe7
--- /dev/null
+++ b/devel/py-ctags/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-ctags
+# Date created: Jan. 27, 2008
+# Whom: Aaron H. K. Diep <ahkdiep@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctags
+PORTVERSION= 1.0.5
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-ctags-${PORTVERSION}
+
+MAINTAINER= ahkdiep@gmail.com
+COMMENT= Python bindings for ctags index file
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-ctags
+PYDISTUTILS_PKGVERSION= 1.0.5
+
+.include <bsd.port.mk>
diff --git a/devel/py-ctags/distinfo b/devel/py-ctags/distinfo
new file mode 100644
index 000000000000..0dc6bf7f2d0e
--- /dev/null
+++ b/devel/py-ctags/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-ctags-1.0.5.tar.gz) = 6579b49942c73abd1d22a5cfd559856b
+SHA256 (python-ctags-1.0.5.tar.gz) = 47eff614b9cc15333bf9d6ca4b2c068802cde2d9328946ed7a1b5e3369e35fe9
+SIZE (python-ctags-1.0.5.tar.gz) = 24274
diff --git a/devel/py-ctags/pkg-descr b/devel/py-ctags/pkg-descr
new file mode 100644
index 000000000000..6ca6cee0824c
--- /dev/null
+++ b/devel/py-ctags/pkg-descr
@@ -0,0 +1,12 @@
+Exuberant Ctags indexing python bindings
+
+Exuberant Ctags supports indexing of many modern programming languages. Python
+is a powerful scriptable dynamic language. Using Python to access Ctags index
+file is a natural fit in extending an application's capability to examine
+source code.
+
+This project wrote a wrapper for readtags.c. I have been using the package in
+a couple of projects and it has been shown that it could easily handle hundreds
+source files.
+
+WWW: http://www.python.org/pypi/python-ctags/
diff --git a/devel/py-ctags/pkg-plist b/devel/py-ctags/pkg-plist
new file mode 100644
index 000000000000..54ed4e62a4bf
--- /dev/null
+++ b/devel/py-ctags/pkg-plist
@@ -0,0 +1,5 @@
+%%PYTHON_SITELIBDIR%%/ctags/__init__.py
+%%PYTHON_SITELIBDIR%%/ctags/_readtags.so
+%%PYTHON_SITELIBDIR%%/ctags/__init__.pyc
+%%PYTHON_SITELIBDIR%%/ctags/__init__.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/ctags