aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-01 13:26:22 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-01 13:26:22 +0800
commitfcdaabe40587bb9116319cdb7d928c8a99ee1904 (patch)
tree3f94a3fec05b017903e24325242e3ee20f4e66f2
parentd967fe50b8483a58d85a9f31dc0100d2fd0cb930 (diff)
downloadfreebsd-ports-gnome-fcdaabe40587bb9116319cdb7d928c8a99ee1904.tar.gz
freebsd-ports-gnome-fcdaabe40587bb9116319cdb7d928c8a99ee1904.tar.zst
freebsd-ports-gnome-fcdaabe40587bb9116319cdb7d928c8a99ee1904.zip
games/qtads: unbreak with clang 4.0
tads3/vmtz.cpp:1985:30: error: ordered comparison between pointer and zero ('vmtz_trans *' and 'int') result->set(tcur > 0 ? tcur - 1 : tcur); ~~~~ ^ ~ PR: 216357 Reported by: antoine (via exp-run) Submitted by: kaiwang27@gmail.com (maintainer)
-rw-r--r--games/qtads/Makefile2
-rw-r--r--games/qtads/files/patch-tads3_vmtz.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/qtads/Makefile b/games/qtads/Makefile
index 4e9384fca989..9ba8d51a86e4 100644
--- a/games/qtads/Makefile
+++ b/games/qtads/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qtads
PORTVERSION= 2.1.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-2.x/${PORTVERSION}
diff --git a/games/qtads/files/patch-tads3_vmtz.cpp b/games/qtads/files/patch-tads3_vmtz.cpp
new file mode 100644
index 000000000000..ff1d29825a57
--- /dev/null
+++ b/games/qtads/files/patch-tads3_vmtz.cpp
@@ -0,0 +1,11 @@
+--- tads3/vmtz.cpp.orig 2012-08-31 05:09:31 UTC
++++ tads3/vmtz.cpp
+@@ -1982,7 +1982,7 @@ void CVmTimeZone::query(vmtzquery *resul
+ * the transition in terms of the local time that was in effect
+ * up until that moment
+ */
+- result->set(tcur > 0 ? tcur - 1 : tcur);
++ result->set(cur > 0 ? tcur - 1 : tcur);
+ return;
+ }
+ }