aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-04-18 09:52:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-04-18 09:52:03 +0800
commitfd03889911d28c2b2489d204f48c4f6a87fa8bc8 (patch)
treea3ef9fac8da6b031bc095f5b8749470077a2b1d0
parent41faed7b85d104c8e13e6f5044d83da8fe6f161d (diff)
downloadfreebsd-ports-gnome-fd03889911d28c2b2489d204f48c4f6a87fa8bc8.tar.gz
freebsd-ports-gnome-fd03889911d28c2b2489d204f48c4f6a87fa8bc8.tar.zst
freebsd-ports-gnome-fd03889911d28c2b2489d204f48c4f6a87fa8bc8.zip
- Add patches to fix build on 10.x+
- Mark BROKEN on 10.x+ It accesses field of structure which was made opaque in r235647 to change internally used file descriptor: cwd.c:892:15: error: incomplete definition of type 'struct _dirdesc' search->dp->dd_fd = squirrel_fd(search->dp->dd_fd); ~~~~~~~~~~^ /usr/include/dirent.h:58:8: note: forward declaration of 'struct _dirdesc' struct _dirdesc; ^ This hack is no longer possible on 10.x+. Doscmd may work fine without it though, but I'm not taking responsibility by blindly removing it. If you know the interlans and can test it, see extra-patch-cwd.c.
-rw-r--r--emulators/doscmd/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/emulators/doscmd/Makefile b/emulators/doscmd/Makefile
index ff23ff8893b6..5d385266a091 100644
--- a/emulators/doscmd/Makefile
+++ b/emulators/doscmd/Makefile
@@ -23,6 +23,11 @@ X11_MAKE_ARGS_OFF= -DNO_X
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000012
+# files/extra-patch-cwd.c will fix this, see inside
+BROKEN= does not build (accesses field of opaque structure)
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1