aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-09-28 10:41:25 +0800
committeryuri <yuri@FreeBSD.org>2018-09-28 10:41:25 +0800
commitfd03dd1ebad2efbf8fd29eddac19b9faed870851 (patch)
treee27b7da297837a11fae626075df3b18594a3ff05
parentc9a3fb217d38ab5a15b3011f2eb568723a9485cb (diff)
downloadfreebsd-ports-gnome-fd03dd1ebad2efbf8fd29eddac19b9faed870851.tar.gz
freebsd-ports-gnome-fd03dd1ebad2efbf8fd29eddac19b9faed870851.tar.zst
freebsd-ports-gnome-fd03dd1ebad2efbf8fd29eddac19b9faed870851.zip
textproc/py-pygments and science/paraview conflict each other
Approved by: portmgr blanket
-rw-r--r--science/paraview/Makefile2
-rw-r--r--textproc/py-pygments/Makefile8
2 files changed, 9 insertions, 1 deletions
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 80af7558a31b..576305dbc217 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -42,6 +42,8 @@ USE_XORG= x11 xt xext ice xdmcp xau xcb xfixes xdamage xxf86vm xrender sm xorgpr
USE_LDCONFIG= yes
USE_GSTREAMER= yes
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pygments
+
CMAKE_ARGS+= -DBUILD_SHARED_LIBS="ON" \
-DVTK_USE_SYSTEM_PNG="ON" \
-DVTK_USE_SYSTEM_JPEG="ON" \
diff --git a/textproc/py-pygments/Makefile b/textproc/py-pygments/Makefile
index 886172945091..a84c9853210f 100644
--- a/textproc/py-pygments/Makefile
+++ b/textproc/py-pygments/Makefile
@@ -17,4 +17,10 @@ USES= python
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} == 2.7
+CONFLICTS_INSTALL= paraview
+.endif
+
+.include <bsd.port.post.mk>