aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-09-07 15:09:09 +0800
committermat <mat@FreeBSD.org>2016-09-07 15:09:09 +0800
commitfd82b02e1efb0706fe0fff06c93a2f9650af30b6 (patch)
treee98a24ba572625ec1cf0fa280b85caf5c0f384c4
parent25f604500d9218bf20d8c149d726c7ad7f955869 (diff)
downloadfreebsd-ports-gnome-fd82b02e1efb0706fe0fff06c93a2f9650af30b6.tar.gz
freebsd-ports-gnome-fd82b02e1efb0706fe0fff06c93a2f9650af30b6.tar.zst
freebsd-ports-gnome-fd82b02e1efb0706fe0fff06c93a2f9650af30b6.zip
Fix SYMLINK option.
When the SYMLINK option was introduce, a new SUB_LIST was too, but it was never used. While there, fix the symlink to be relative, like it should. PR: 212107 Submitted by: mat Approved by: maintainer timeout Sponsored by: Absolight
-rw-r--r--www/rubygem-passenger/Makefile3
-rw-r--r--www/rubygem-passenger/files/pkg-message.in4
2 files changed, 4 insertions, 3 deletions
diff --git a/www/rubygem-passenger/Makefile b/www/rubygem-passenger/Makefile
index 6e8fdf4a819a..dabf897fcd2c 100644
--- a/www/rubygem-passenger/Makefile
+++ b/www/rubygem-passenger/Makefile
@@ -3,6 +3,7 @@
PORTNAME= passenger
PORTVERSION= 5.0.30
+PORTREVISION= 1
CATEGORIES= www rubygems
MASTER_SITES= RG
PKGNAMEPREFIX= rubygem-
@@ -96,7 +97,7 @@ post-install:
${COPYTREE_SHARE} buildout ${STAGEDIR}${PREFIX}/${GEMS_DIR}/${PORTNAME}-${PORTVERSION} )
${CHMOD} +x ${STAGEDIR}${PREFIX}/${GEMS_DIR}/${PORTNAME}-${PORTVERSION}/buildout/support-binaries/*
.if ${PORT_OPTIONS:MSYMLINK}
- ${LN} -s ${PREFIX}/${GEM_LIB_DIR} ${STAGEDIR}${PREFIX}/${GEMS_DIR}/${PORTNAME}
+ ${LN} -s ${GEM_NAME} ${STAGEDIR}${PREFIX}/${GEMS_DIR}/${PORTNAME}
.endif
.include <bsd.port.mk>
diff --git a/www/rubygem-passenger/files/pkg-message.in b/www/rubygem-passenger/files/pkg-message.in
index c61be67b9415..38ad68aaaf11 100644
--- a/www/rubygem-passenger/files/pkg-message.in
+++ b/www/rubygem-passenger/files/pkg-message.in
@@ -2,8 +2,8 @@
Please edit your Apache configuration file, and add these lines:
- LoadModule passenger_module %%PREFIX%%/%%GEM_LIB_DIR%%/buildout/apache2/mod_passenger.so
- PassengerRoot %%PREFIX%%/%%GEM_LIB_DIR%%
+ LoadModule passenger_module %%PASSENGER_INSTALL_DIR%%/buildout/apache2/mod_passenger.so
+ PassengerRoot %%PASSENGER_INSTALL_DIR%%
PassengerRuby %%RUBY%%
After you restart Apache, you are ready to deploy any number of Ruby on Rails