aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-10-17 06:55:49 +0800
committeravilla <avilla@FreeBSD.org>2011-10-17 06:55:49 +0800
commitfecd723cb5143af4cfae881f7b79e9283cf7e616 (patch)
tree1b7556896d5fdc56d10191f7ca4485ba484f8c08
parent081315676be3c24e71f0cba71b5231795fe29ed9 (diff)
downloadfreebsd-ports-gnome-fecd723cb5143af4cfae881f7b79e9283cf7e616.tar.gz
freebsd-ports-gnome-fecd723cb5143af4cfae881f7b79e9283cf7e616.tar.zst
freebsd-ports-gnome-fecd723cb5143af4cfae881f7b79e9283cf7e616.zip
- Fix build with raptor2.
- Bump PORTREVISION.
-rw-r--r--editors/morla/Makefile3
-rw-r--r--editors/morla/files/patch-src__query.c27
2 files changed, 29 insertions, 1 deletions
diff --git a/editors/morla/Makefile b/editors/morla/Makefile
index f8a3d6732a90..9ff59076e101 100644
--- a/editors/morla/Makefile
+++ b/editors/morla/Makefile
@@ -7,7 +7,7 @@
PORTNAME= morla
PORTVERSION= 0.16.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= editors textproc
MASTER_SITES= http://www.morlardf.net/src/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
@@ -17,6 +17,7 @@ COMMENT= A RDF editor
LIB_DEPENDS= nxml.18:${PORTSDIR}/textproc/libnxml \
rdf.0:${PORTSDIR}/textproc/redland \
+ raptor2.0:${PORTSDIR}/textproc/raptor2 \
curl.6:${PORTSDIR}/ftp/curl
BUILD_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
diff --git a/editors/morla/files/patch-src__query.c b/editors/morla/files/patch-src__query.c
new file mode 100644
index 000000000000..094afece5197
--- /dev/null
+++ b/editors/morla/files/patch-src__query.c
@@ -0,0 +1,27 @@
+--- ./src/query.c.orig 2011-10-02 23:46:35.559557849 +0200
++++ ./src/query.c 2011-10-02 23:50:37.359563100 +0200
+@@ -1400,7 +1400,11 @@
+ #endif
+
+ uri_string = raptor_uri_filename_to_uri_string ("");
++#ifdef USE_RASQAL_OLD
+ base_uri = raptor_new_uri (uri_string);
++#else
++ base_uri = raptor_new_uri (rasqal, uri_string);
++#endif
+ raptor_free_memory (uri_string);
+ }
+
+@@ -1419,11 +1423,7 @@
+
+ if (query)
+ {
+- rasqal_query_set_fatal_error_handler (query, NULL,
+- query_rasqal_error);
+- rasqal_query_set_error_handler (query, NULL, query_rasqal_error);
+- rasqal_query_set_warning_handler (query, NULL,
+- query_rasqal_warning);
++ rasqal_world_set_log_handler (query, NULL, query_rasqal_error);
+
+ if (rasqal_query_prepare
+ (query, (const unsigned char *) buf, base_uri))