aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2009-10-31 20:49:47 +0800
committerwen <wen@FreeBSD.org>2009-10-31 20:49:47 +0800
commitfef3ff6dd3bd59de4a346d043814fcecbba92790 (patch)
tree5357dc23c3bb1966ca23cbb5ded33b2f8f8d6eb5
parentd0bdf40deb8644135c6fc0cc9abdd2dc6d66e9f7 (diff)
downloadfreebsd-ports-gnome-fef3ff6dd3bd59de4a346d043814fcecbba92790.tar.gz
freebsd-ports-gnome-fef3ff6dd3bd59de4a346d043814fcecbba92790.tar.zst
freebsd-ports-gnome-fef3ff6dd3bd59de4a346d043814fcecbba92790.zip
Pod::Autopod is designed to generate pod documentation of a perl
class by analysing its code. The idea is to have something similar like javadoc. So it uses also comments written directly obove the method definitions. It is designed to asumes a pm file which represents a class. Of course it can not understand every kind of syntax, parameters, etc. But the plan is to improve this library in the future to understand more and more automatically. WWW: http://search.cpan.org/dist/Pod-Autopod/ Approved by: miwi,jadawin(mentors,implicit)
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Pod-Autopod/Makefile25
-rw-r--r--textproc/p5-Pod-Autopod/distinfo3
-rw-r--r--textproc/p5-Pod-Autopod/pkg-descr11
-rw-r--r--textproc/p5-Pod-Autopod/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ce5ae8b06579..a2126ced36f5 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -537,6 +537,7 @@
SUBDIR += p5-Plucene-Plugin-Analyzer-SnowballAnalyzer
SUBDIR += p5-Plucene-Simple
SUBDIR += p5-Pod-Abstract
+ SUBDIR += p5-Pod-Autopod
SUBDIR += p5-Pod-Constants
SUBDIR += p5-Pod-DocBook
SUBDIR += p5-Pod-Escapes
diff --git a/textproc/p5-Pod-Autopod/Makefile b/textproc/p5-Pod-Autopod/Makefile
new file mode 100644
index 000000000000..41af8e2541ce
--- /dev/null
+++ b/textproc/p5-Pod-Autopod/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Pod-Autopod
+# Date created: 31 Oct, 2009
+# Whom: Wen Heping<wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-Autopod
+PORTVERSION= 1.07
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Generates pod documentation by analysing perl modules
+
+BUILD_DEPENDS= p5-Pod-Abstract>=0.19:${PORTSDIR}/textproc/p5-Pod-Abstract
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= autopod.1
+MAN3= Pod::Autopod.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Autopod/distinfo b/textproc/p5-Pod-Autopod/distinfo
new file mode 100644
index 000000000000..b969e327535b
--- /dev/null
+++ b/textproc/p5-Pod-Autopod/distinfo
@@ -0,0 +1,3 @@
+MD5 (Pod-Autopod-1.07.tar.gz) = b9c87bc1cc804a504113ab19ffd576d5
+SHA256 (Pod-Autopod-1.07.tar.gz) = 87b06a99a343c8f17099a82e94cfa83c0b697608bf396efd60be3e2e88cb25a3
+SIZE (Pod-Autopod-1.07.tar.gz) = 10180
diff --git a/textproc/p5-Pod-Autopod/pkg-descr b/textproc/p5-Pod-Autopod/pkg-descr
new file mode 100644
index 000000000000..c9715645542c
--- /dev/null
+++ b/textproc/p5-Pod-Autopod/pkg-descr
@@ -0,0 +1,11 @@
+Pod::Autopod is designed to generate pod documentation of a perl
+class by analysing its code. The idea is to have something similar
+like javadoc. So it uses also comments written directly obove the
+method definitions. It is designed to asumes a pm file which
+represents a class.
+
+Of course it can not understand every kind of syntax, parameters,
+etc. But the plan is to improve this library in the future to
+understand more and more automatically.
+
+WWW: http://search.cpan.org/dist/Pod-Autopod/
diff --git a/textproc/p5-Pod-Autopod/pkg-plist b/textproc/p5-Pod-Autopod/pkg-plist
new file mode 100644
index 000000000000..fb77936524f9
--- /dev/null
+++ b/textproc/p5-Pod-Autopod/pkg-plist
@@ -0,0 +1,6 @@
+bin/autopod
+%%SITE_PERL%%/Pod/Autopod.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Autopod/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Autopod
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod
+@dirrmtry %%SITE_PERL%%/Pod