aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-04 20:33:50 +0800
committeraz <az@FreeBSD.org>2013-08-04 20:33:50 +0800
commit011dfc223a3e770d65629c310a64d8d29be38457 (patch)
treeb568b4caef2c226792fbbfb3dfc4d1e4c299d61b
parente21178d47577200e50a8e105029f7d2bfdf408b1 (diff)
downloadfreebsd-ports-gnome-011dfc223a3e770d65629c310a64d8d29be38457.tar.gz
freebsd-ports-gnome-011dfc223a3e770d65629c310a64d8d29be38457.tar.zst
freebsd-ports-gnome-011dfc223a3e770d65629c310a64d8d29be38457.zip
- Convert to new perl framework
Approved by: bapt@ (maintainer)
-rw-r--r--mail/prayer/Makefile4
-rw-r--r--x11-wm/i3/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/mail/prayer/Makefile b/mail/prayer/Makefile
index 95cbb040a3c2..7c3bc3a52424 100644
--- a/mail/prayer/Makefile
+++ b/mail/prayer/Makefile
@@ -12,8 +12,8 @@ LICENSE= GPLv2
LIB_DEPENDS= c-client4:${PORTSDIR}/mail/cclient
-USE_PERL5_BUILD=yes
-USES= iconv shebangfix gmake
+USES= iconv shebangfix gmake perl5
+USE_PERL5= build
LDFLAGS+= -L${LOCALBASE}/lib
SHEBANG_FILES= utils/ucsnews.pl \
diff --git a/x11-wm/i3/Makefile b/x11-wm/i3/Makefile
index 9c939b0bfe94..d836707f1a90 100644
--- a/x11-wm/i3/Makefile
+++ b/x11-wm/i3/Makefile
@@ -27,10 +27,10 @@ RUN_DEPENDS= p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
p5-AnyEvent-I3>=0:${PORTSDIR}/devel/p5-AnyEvent-I3
-USE_PERL5_RUN= yes
USE_XORG= x11 xcb xcursor
-USES= pkgconfig iconv gmake
+USES= pkgconfig iconv gmake perl5
USE_BZIP2= yes
+USE_PERL5= run
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/i3 \