aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-06-02 05:52:19 +0800
committerswills <swills@FreeBSD.org>2013-06-02 05:52:19 +0800
commit02a658d35666f678fef6c98aa82c3a8000241555 (patch)
treeae72c177c1ce130ba7c8aa1cfe9ebe0977f02861
parent32f659a88d8db461f0fbf85f5179777a32b9df71 (diff)
downloadfreebsd-ports-gnome-02a658d35666f678fef6c98aa82c3a8000241555.tar.gz
freebsd-ports-gnome-02a658d35666f678fef6c98aa82c3a8000241555.tar.zst
freebsd-ports-gnome-02a658d35666f678fef6c98aa82c3a8000241555.zip
- Add X11 option
PR: ports/178044 Submitted by: David Demelier <demelier.david@gmail.com>
-rw-r--r--graphics/ruby-rmagick/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/ruby-rmagick/Makefile b/graphics/ruby-rmagick/Makefile
index d7e32bd51973..16a8844f99f2 100644
--- a/graphics/ruby-rmagick/Makefile
+++ b/graphics/ruby-rmagick/Makefile
@@ -13,7 +13,18 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby binding for ImageMagick
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT= X11
+
+OPTIONSFILE?= ${PORT_DBDIR}/ruby-${PORTNAME}/options
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick
+.else
+LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick-nox11
+.endif
USE_BZIP2= yes
USE_RUBY= yes