aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-10-05 18:23:22 +0800
committermiwi <miwi@FreeBSD.org>2008-10-05 18:23:22 +0800
commit03041e9b2df091f4f7dd962498b056900a4cf36a (patch)
treeaad5912dffcfc96818b54ab61be4867bdec9a911
parenta44b88a5619050032b42951103154a7372855ff0 (diff)
downloadfreebsd-ports-gnome-03041e9b2df091f4f7dd962498b056900a4cf36a.tar.gz
freebsd-ports-gnome-03041e9b2df091f4f7dd962498b056900a4cf36a.tar.zst
freebsd-ports-gnome-03041e9b2df091f4f7dd962498b056900a4cf36a.zip
- Update to 0.0.16
PR: 127426 Submitted by: Henrik Friedrichsen <hrkfrd@googlemail.com> (maintainer)
-rw-r--r--net-im/pidgin-msn-pecan/Makefile10
-rw-r--r--net-im/pidgin-msn-pecan/distinfo6
-rw-r--r--net-im/pidgin-msn-pecan/files/patch-Makefile25
3 files changed, 23 insertions, 18 deletions
diff --git a/net-im/pidgin-msn-pecan/Makefile b/net-im/pidgin-msn-pecan/Makefile
index e95f2accb80b..b71295f82a8d 100644
--- a/net-im/pidgin-msn-pecan/Makefile
+++ b/net-im/pidgin-msn-pecan/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= msn-pecan
-PORTVERSION= 0.0.15
+PORTVERSION= 0.0.16
CATEGORIES= net-im
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= pidgin-
@@ -22,7 +22,13 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_GETTEXT= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BROKEN= does not compile on FreeBSD 6.X
+.endif
+
post-install:
${GMAKE} -C ${WRKSRC} install_locales
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-im/pidgin-msn-pecan/distinfo b/net-im/pidgin-msn-pecan/distinfo
index 62b224c47b0f..a61e930f557b 100644
--- a/net-im/pidgin-msn-pecan/distinfo
+++ b/net-im/pidgin-msn-pecan/distinfo
@@ -1,3 +1,3 @@
-MD5 (msn-pecan-0.0.15.tar.bz2) = bc04bc322cdaf9ddcbc1604c1d20b47a
-SHA256 (msn-pecan-0.0.15.tar.bz2) = cac47e053e189adc963e03c5e02ae4b2ecf11f01b9804e5ee2b5e6b07fdb5e4d
-SIZE (msn-pecan-0.0.15.tar.bz2) = 114981
+MD5 (msn-pecan-0.0.16.tar.bz2) = 4f999947fca7e463cf423208a9bdac00
+SHA256 (msn-pecan-0.0.16.tar.bz2) = 1ebdb8603b40b74fca25f90ff4d32b05a83650d999ea8b4bc8bc23fd6218dc48
+SIZE (msn-pecan-0.0.16.tar.bz2) = 117322
diff --git a/net-im/pidgin-msn-pecan/files/patch-Makefile b/net-im/pidgin-msn-pecan/files/patch-Makefile
index 3bbc36afbfab..07d9ac2b22f8 100644
--- a/net-im/pidgin-msn-pecan/files/patch-Makefile
+++ b/net-im/pidgin-msn-pecan/files/patch-Makefile
@@ -1,29 +1,28 @@
---- Makefile.orig 2008-08-29 06:15:22.000000000 +0800
-+++ Makefile 2008-09-01 03:46:46.000000000 +0800
-@@ -27,16 +27,16 @@
+diff -Naur ./Makefile ../pecan/Makefile
+--- ./Makefile 2008-09-16 21:42:17.000000000 +0200
++++ ../pecan/Makefile 2008-09-16 21:45:04.000000000 +0200
+@@ -29,7 +29,7 @@
OTHER_WARNINGS=-D_FORTIFY_SOURCE=2 -fstack-protector -g3 -Wdisabled-optimization \
-Wendif-labels -Wformat=2 -Wstack-protector -Wswitch
-CFLAGS+=-Wall # $(EXTRA_WARNINGS)
+CFLAGS+=-Wall -I/usr/local/include # $(EXTRA_WARNINGS)
- override CFLAGS+=-I. -D PACKAGE='"msn-pecan"' -DENABLE_NLS -DHAVE_LIBPURPLE -DPURPLE_DEBUG -D PLUGIN_NAME='msn-pecan'
-
+ override CFLAGS+=-I. -D PACKAGE='"libmsn-pecan"' -DENABLE_NLS -DHAVE_LIBPURPLE -DPURPLE_DEBUG -DLIBPURPLE_NEW_API \
+ -D PLUGIN_NAME='msn-pecan'
+@@ -43,7 +43,7 @@
# For glib < 2.6 support (libpurple maniacs)
FALLBACK_CFLAGS+=-I./fix_purple
-LDFLAGS:=-Wl,--no-undefined
+LDFLAGS:=-Wl,--no-undefined,-lintl
--DATA_DIR=/usr/share
-+DATA_DIR=/usr/local/share
-
- purpledir=$(DESTDIR)/$(PURPLE_PREFIX)/lib/purple-2
-
-@@ -180,5 +180,5 @@
+ prefix=$(DESTDIR)/$(PURPLE_PREFIX)
+ plugin_dir=$(prefix)/lib/purple-2
+@@ -199,5 +199,5 @@
install_locales: $(foreach e,$(CATALOGS),po/libmsn-pecan-$(e).mo)
for x in $(CATALOGS); do \
-- install po/libmsn-pecan-$$x.mo $(DATA_DIR)/locale/$$x/LC_MESSAGES/libmsn-pecan.mo; \
-+ install -m 444 po/libmsn-pecan-$$x.mo $(DATA_DIR)/locale/$$x/LC_MESSAGES/libmsn-pecan.mo; \
+- install -D po/libmsn-pecan-$$x.mo $(data_dir)/locale/$$x/LC_MESSAGES/libmsn-pecan.mo; \
++ install -m 444 po/libmsn-pecan-$$x.mo $(data_dir)/locale/$$x/LC_MESSAGES/libmsn-pecan.mo; \
done