aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormax <max@FreeBSD.org>2001-11-22 12:59:37 +0800
committermax <max@FreeBSD.org>2001-11-22 12:59:37 +0800
commit0366d49c4f4bd9ac708cf565a1525aa4ec365635 (patch)
tree2ccd4ecf1a06e8bf9eb9fdeebd2ab5d57fee8d8c
parentf3af5bad69d14bfb6acd3360f2fc17b5e1456cde (diff)
downloadfreebsd-ports-gnome-0366d49c4f4bd9ac708cf565a1525aa4ec365635.tar.gz
freebsd-ports-gnome-0366d49c4f4bd9ac708cf565a1525aa4ec365635.tar.zst
freebsd-ports-gnome-0366d49c4f4bd9ac708cf565a1525aa4ec365635.zip
Unbreak this port. (Still forbidden, though.)
While I was at it, changed it to use newer (sort of) distfile and patch. I considered removing this port from the collection since mail/pine4 supports Japanese in certain extent. However, this port provides an editor with Japanese input support as well as help files in Japanese, which may be value for some people. With this commit, I'm closing: PR: 16872
-rw-r--r--japanese/pine/Makefile34
-rw-r--r--japanese/pine/distinfo5
-rw-r--r--japanese/pine/files/patch-ab214
-rw-r--r--japanese/pine/pkg-descr10
-rw-r--r--japanese/pine/pkg-plist3
5 files changed, 132 insertions, 134 deletions
diff --git a/japanese/pine/Makefile b/japanese/pine/Makefile
index e2752fbee0c7..ae357790b7e8 100644
--- a/japanese/pine/Makefile
+++ b/japanese/pine/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: jp-pine
+# New ports collection makefile for: ja-pine
# Date created: 01 May 1996
# Whom: masafumi
#
@@ -6,35 +6,30 @@
#
PORTNAME= pine
-PORTVERSION= 3.95
+PORTVERSION= 3.96
CATEGORIES= japanese mail
-MASTER_SITES= ftp://ftp.cac.washington.edu/pine/ \
- ${MASTER_SITE_PORTS_JP}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${DISTNAME}lj1.1b2.tar.gz
+MASTER_SITES= ftp://ftp.cac.washington.edu/pine/old/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= max
DISTNAME= ${PORTNAME}${PORTVERSION}
-
-PATCHFILES= ${DISTNAME}lj1.1b2-b3.diff.gz
-PATCH_SITES= ${MASTER_SITE_PORTS_JP}
+DISTFILES= ${DISTNAME}.tar.Z \${PORTNAME}${PORTVERSION}.tar.Z \
+ ${DISTNAME}lj1.1b7.tar.gz
+EXTRACT_ONLY= ${DISTNAME}.tar.Z
MAINTAINER= max@FreeBSD.org
-FORBIDDEN= "Remotely exploitable buffer overflows."
+LIB_DEPENDS= canna.1:${PORTSDIR}/japanese/Canna
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcanna.a:${PORTSDIR}/japanese/Canna
-BROKEN_ELF= yes
+FORBIDDEN= "Remotely exploitable buffer overflows."
INSTALLS_SHLIB= yes
-
-LIB_DEPENDS= canna.1:${PORTSDIR}/japanese/Canna
-BUILD_DEPENDS= ${PREFIX}/lib/libcanna.a:${PORTSDIR}/japanese/Canna
-
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAN1= pine.1 pilot.1 pico.1
pre-patch:
@(cd ${WRKSRC}; \
- ${TAR} zxf ${DISTDIR}/${DISTNAME}lj1.1b2.tar.gz; \
- ${PATCH} -s -p0 < japan/${DISTNAME}lj1.1b2.diff)
+ ${TAR} zxf ${DISTDIR}/${DISTNAME}lj1.1b7.tar.gz; \
+ ${PATCH} -s -p1 < ${DISTNAME}lj1.1b7.diff)
do-build:
(cd ${WRKSRC}; ./build bsf)
@@ -43,7 +38,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/pico ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bin/pilot ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bin/pine ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/bin/libpico.so.1.3 $(PREFIX)/lib
+ ${INSTALL_DATA} ${WRKSRC}/bin/libpico.so.1.3 $(PREFIX)/lib/libpico.so.1
+ ${LN} -sf ${PREFIX}/lib/libpico.so.1 ${PREFIX}/lib/libpico.so
${INSTALL_MAN} ${WRKSRC}/doc/pico.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/pilot.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/pine.1 ${PREFIX}/man/man1
diff --git a/japanese/pine/distinfo b/japanese/pine/distinfo
index fba68dd421b9..a07e28593011 100644
--- a/japanese/pine/distinfo
+++ b/japanese/pine/distinfo
@@ -1,3 +1,2 @@
-MD5 (pine3.95.tar.gz) = e99dd57904a035571776d7dc0c632d46
-MD5 (pine3.95lj1.1b2.tar.gz) = 13d549f7140e2c85c417dbed397a7810
-MD5 (pine3.95lj1.1b2-b3.diff.gz) = 5ea9dfcbc92de6da4c5efb8453a33fd7
+MD5 (pine3.96.tar.Z) = 37138f0d1ec3175cf1ffe6c062c9abbf
+MD5 (pine3.96lj1.1b7.tar.gz) = ef5f85ac183790528f0b1adc34fe7af8
diff --git a/japanese/pine/files/patch-ab b/japanese/pine/files/patch-ab
index a4a347426dbb..2e9ec0c91a91 100644
--- a/japanese/pine/files/patch-ab
+++ b/japanese/pine/files/patch-ab
@@ -1,106 +1,108 @@
-*** pico/makefile.bsf.orig Fri Sep 20 13:44:43 1996
---- pico/makefile.bsf Fri Sep 20 13:44:43 1996
-***************
-*** 0 ****
---- 1,101 ----
-+ #
-+ # Michael Seibel
-+ # Networks and Distributed Computing
-+ # Computing and Communications
-+ # University of Washington
-+ # Administration Builiding, AG-44
-+ # Seattle, Washington, 98195, USA
-+ # Internet: mikes@cac.washington.edu
-+ #
-+ # Please address all bugs and comments to "pine-bugs@cac.washington.edu"
-+ #
-+ #
-+ # Pine and Pico are registered trademarks of the University of Washington.
-+ # No commercial use of these trademarks may be made without prior written
-+ # permission of the University of Washington.
-+ #
-+ # Pine, Pico, and Pilot software and its included text are Copyright
-+ # 1989-1996 by the University of Washington.
-+ #
-+ # The full text of our legal notices is contained in the file called
-+ # CPYRIGHT, included with this distribution.
-+ #
-+
-+ #
-+ # Makefile for the FreeBSD shared-lib version of the PINE composer library and
-+ # stand-alone editor pico.
-+ #
-+
-+ #includes symbol info for debugging
-+ DASHO= # -g
-+ #for normal build
-+ #DASHO= -O
-+
-+ STDCFLAGS= -DBSDI -DBSDI2 -DPOSIX -DJOB_CONTROL -DANSI -DMOUSE \
-+ -I/usr/local/include
-+ EXTRACFLAGS= -DKANJI -DCANNA -DHELPFILE
-+ CFLAGS+= $(EXTRACFLAGS) $(DASHO) $(STDCFLAGS)
-+
-+ # switches for library building
-+ LIBCMD= ar
-+ LIBARGS= ru
-+ RANLIB= ranlib
-+
-+ EXTRALIBES= -lcanna -L/usr/local/lib
-+ LIBS= $(EXTRALIBES) -ltermcap
-+
-+ OFILES= attach.o ansi.o basic.o bind.o browse.o buffer.o \
-+ composer.o display.o file.o fileio.o line.o osdep.o \
-+ pico.o random.o region.o search.o spell.o tcap.o window.o \
-+ word.o kanji.o jctype.o canna.o
-+
-+ # Lets be elite and not retype in the above
-+ SOFILES= ${OFILES:.o=.so}
-+
-+ CFILES= attach.c ansi.c basic.c bind.c browse.c buffer.c \
-+ composer.c display.c file.c fileio.c line.c osdep.c \
-+ pico.c random.c region.c search.c spell.c tcap.c window.c \
-+ word.c kanji.c jctype.c canna.c
-+
-+ HFILES= estruct.h edef.h efunc.h ebind.h pico.h osdep.h \
-+ kanji.h jctype.h canna.h
-+
-+ # Need this for the shared library rule to work correctly
-+ .SUFFIXES: .o .so
-+
-+ #
-+ # dependencies for the Unix versions of pico and libpico.a
-+ #
-+ all: pico pilot
-+
-+ osdep.c: os_unix.c
-+ rm -f osdep.c
-+ cp os_unix.c osdep.c
-+
-+ osdep.h: os_unix.h
-+ rm -f osdep.h
-+ cp os_unix.h osdep.h
-+
-+ libpico.a: osdep.c osdep.h $(OFILES)
-+ $(LIBCMD) $(LIBARGS) libpico.a $(OFILES)
-+ $(RANLIB) libpico.a
-+
-+ libpico.so.1.3: osdep.c osdep.h $(SOFILES)
-+ ld -Bshareable -x -o libpico.so.1.3 $(SOFILES)
-+
-+ pico: main.c libpico.so.1.3
-+ $(CC) $(CFLAGS) main.c -L. -lpico $(LIBS) -o pico
-+
-+ pilot: pilot.c libpico.so.1.3
-+ $(CC) $(CFLAGS) pilot.c -L. -lpico $(LIBS) -o pilot
-+
-+ .c.so: ; $(CC) -fpic -DPIC -c $(CFLAGS) ${@:.so=.c} -o $@
-+
-+ .c.o: ; $(CC) -c $(CFLAGS) $*.c
-+
-+ $(OFILES): $(HFILES)
-+
-+ $(SOFILES): $(HFILES)
-+
-+ clean:
-+ rm -f *.a *.so.1.3 *.o *.so *~ osdep.c osdep.h pico pilot
+--- pico/makefile.bsf.orig Wed Nov 21 16:35:55 2001
++++ pico/makefile.bsf Wed Nov 21 16:43:55 2001
+@@ -0,0 +1,105 @@
++#
++# Michael Seibel
++# Networks and Distributed Computing
++# Computing and Communications
++# University of Washington
++# Administration Builiding, AG-44
++# Seattle, Washington, 98195, USA
++# Internet: mikes@cac.washington.edu
++#
++# Please address all bugs and comments to "pine-bugs@cac.washington.edu"
++#
++#
++# Pine and Pico are registered trademarks of the University of Washington.
++# No commercial use of these trademarks may be made without prior written
++# permission of the University of Washington.
++#
++# Pine, Pico, and Pilot software and its included text are Copyright
++# 1989-1996 by the University of Washington.
++#
++# The full text of our legal notices is contained in the file called
++# CPYRIGHT, included with this distribution.
++#
++
++#
++# Makefile for the FreeBSD shared-lib version of the PINE composer library and
++# stand-alone editor pico.
++#
++
++#includes symbol info for debugging
++DASHO= # -g
++#for normal build
++#DASHO= -O
++
++STDCFLAGS= -DBSDI -DBSDI2 -DPOSIX -DJOB_CONTROL -DANSI -DMOUSE \
++ -I/usr/local/include
++EXTRACFLAGS= -DKANJI -DCANNA -DHELPFILE
++CFLAGS+= $(EXTRACFLAGS) $(DASHO) $(STDCFLAGS)
++
++# switches for library building
++LIBCMD= ar
++LIBARGS= ru
++RANLIB= ranlib
++
++EXTRALIBES= -lcanna -L/usr/local/lib
++LIBS= $(EXTRALIBES) -ltermcap
++
++OFILES= attach.o ansi.o basic.o bind.o browse.o buffer.o \
++ composer.o display.o file.o fileio.o line.o osdep.o \
++ pico.o random.o region.o search.o spell.o tcap.o window.o \
++ word.o kanji.o jctype.o canna.o
++
++# Lets be elite and not retype in the above
++SOFILES= ${OFILES:.o=.so}
++
++CFILES= attach.c ansi.c basic.c bind.c browse.c buffer.c \
++ composer.c display.c file.c fileio.c line.c osdep.c \
++ pico.c random.c region.c search.c spell.c tcap.c window.c \
++ word.c kanji.c jctype.c canna.c
++
++HFILES= estruct.h edef.h efunc.h ebind.h pico.h osdep.h \
++ kanji.h jctype.h canna.h
++
++# Need this for the shared library rule to work correctly
++.SUFFIXES: .o .so
++
++#
++# dependencies for the Unix versions of pico and libpico.a
++#
++all: pico pilot
++
++osdep.c: os_unix.c
++ rm -f osdep.c
++ cp os_unix.c osdep.c
++
++osdep.h: os_unix.h
++ rm -f osdep.h
++ cp os_unix.h osdep.h
++
++libpico.a: osdep.c osdep.h $(OFILES)
++ $(LIBCMD) $(LIBARGS) libpico.a $(OFILES)
++ $(RANLIB) libpico.a
++
++libpico.so.1.3: osdep.c osdep.h $(SOFILES)
++ ld -Bshareable -x -o libpico.so.1.3 $(SOFILES)
++
++libpico.so: libpico.so.1.3
++ ln -sf libpico.so.1.3 libpico.so
++
++pico: main.c libpico.so
++ $(CC) $(CFLAGS) main.c -L. -lpico $(LIBS) -o pico
++
++pilot: pilot.c libpico.so.1.3
++ $(CC) $(CFLAGS) pilot.c -L. -lpico $(LIBS) -o pilot
++
++.c.so: ; $(CC) -fpic -DPIC -c $(CFLAGS) ${@:.so=.c} -o $@
++
++.c.o: ; $(CC) -c $(CFLAGS) $*.c
++
++$(OFILES): $(HFILES)
++
++$(SOFILES): $(HFILES)
++
++clean:
++ rm -f *.a *.so *.o *.so *~ osdep.c osdep.h pico pilot
++
diff --git a/japanese/pine/pkg-descr b/japanese/pine/pkg-descr
index 7cc83c75415b..e2bf65bcb7f4 100644
--- a/japanese/pine/pkg-descr
+++ b/japanese/pine/pkg-descr
@@ -9,9 +9,9 @@ and a POP3 server.
This version supports kanji input using Canna. Canna can be started
by ^@ (or ctrl-space) in the Pico editor.
-If you want to use the spell checking feature of pine, set the
-environment variable SPELL to "/usr/local/bin/ispell -l".
+Note: Users are strongly encouraged to install pine4 package instead,
+since pine 3 is known to contain security problems, as well as pine
+4.x supports Japanese. However, pine3 with Japanese support provides
+help files in Japanese and the pico editor supports input using Canna.
-An optional configuration file "pine.conf" can be put into /usr/local/etc
-to set system wide defaults. The format of this file is identical to the
-.pinerc file that is auto-generated by pine in your home directory.
+- Max
diff --git a/japanese/pine/pkg-plist b/japanese/pine/pkg-plist
index ff4c57566a6c..3d899dfadb84 100644
--- a/japanese/pine/pkg-plist
+++ b/japanese/pine/pkg-plist
@@ -1,7 +1,8 @@
bin/pico
bin/pilot
bin/pine
-lib/libpico.so.1.3
+lib/libpico.so.1
+lib/libpico.so
lib/pine/pine.hlp
lib/pine/pine.ndx
lib/pine/pine_ja.hlp