aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-05-08 13:53:18 +0800
committerdinoex <dinoex@FreeBSD.org>2002-05-08 13:53:18 +0800
commit0554b71702fe90de0e599d92dc5ed95693277f64 (patch)
tree499b1bc45053489bf14a63b5908bfb6519e0d225
parent2e795799767cb6f11370e56775c677081d5d7497 (diff)
downloadfreebsd-ports-gnome-0554b71702fe90de0e599d92dc5ed95693277f64.tar.gz
freebsd-ports-gnome-0554b71702fe90de0e599d92dc5ed95693277f64.tar.zst
freebsd-ports-gnome-0554b71702fe90de0e599d92dc5ed95693277f64.zip
- make it work with newer SSL
( same hack as in suck, openssh and openssh-portable ) USE_OPENSSL should be improved, see PR: ports/36080 PR: 36080
-rw-r--r--www/apache13-modssl/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index d39c61eab371..d7061df626b8 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -78,9 +78,19 @@ CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
-fexpensive-optimizations -ffast-math
.endif
+.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
+OPENSSLBASE= ${LOCALBASE}
+OPENSSLDIR= ${OPENSSLBASE}/openssl
+LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
+OPENSSLLIB= ${OPENSSLBASE}/lib
+OPENSSLINC= ${OPENSSLBASE}/include
+MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
+ OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
+.endif
+
CONFIGURE_ENV= CFLAGS='${CFLAGS}' \
OPTIM='${OPTIM}' \
- SSL_BASE='SYSTEM' \
+ SSL_BASE='${OPENSSLBASE}' \
EAPI_MM='SYSTEM' \
PATH="${PREFIX}/bin:${PATH}"