aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-11-10 06:17:07 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:54:53 +0800
commit05a0dd91364101fe12396e025537b521a89e3304 (patch)
treecb6cd4699702d71ff84ff3a3fdaa47ee071463e4
parent85ddf486baf8fdb3376328d311e8bf00c1e0b199 (diff)
downloadfreebsd-ports-gnome-05a0dd91364101fe12396e025537b521a89e3304.tar.gz
freebsd-ports-gnome-05a0dd91364101fe12396e025537b521a89e3304.tar.zst
freebsd-ports-gnome-05a0dd91364101fe12396e025537b521a89e3304.zip
Fix the context of some patches so that they apply with stricter patch(1)
PR: 223545 With hat: portmgr
-rw-r--r--cad/meshlab/files/patch-common_common.pro15
-rw-r--r--cad/qcad/files/patch-src_core_RS.cpp14
-rw-r--r--databases/postgresql-libpqxx3/files/patch-svn_183345
-rw-r--r--emulators/pcsxr/files/patch-pixmaps-Makefile.am8
-rw-r--r--games/blockout/Makefile5
-rw-r--r--graphics/dia/files/patch-app_main.c17
-rw-r--r--graphics/dia/files/patch-doc_fr_Makefile.in4
-rw-r--r--www/domoticz/files/patch-appversion.default10
-rw-r--r--x11-themes/murrine-configurator/files/patch-files__murrine-configurator5
-rw-r--r--x11-toolkits/hs-wx/Makefile2
-rw-r--r--x11-toolkits/hs-wx/files/patch-src_Graphics_UI_WX_Window.hs8
11 files changed, 76 insertions, 57 deletions
diff --git a/cad/meshlab/files/patch-common_common.pro b/cad/meshlab/files/patch-common_common.pro
index c3be6a6c3efe..11bcb9195e1f 100644
--- a/cad/meshlab/files/patch-common_common.pro
+++ b/cad/meshlab/files/patch-common_common.pro
@@ -1,8 +1,11 @@
---- common/common.pro.orig 2013-10-31 13:57:32.000000000 +0100
-+++ common/common.pro 2013-10-31 14:00:10.000000000 +0100
-@@ -126,3 +126,5 @@
- linux-g++-64:LIBS += -L../external/lib/linux-g++-64 -ljhead
-
- #RESOURCES = common.qrc
+--- common/common.pro.orig 2014-02-07 09:38:24 UTC
++++ common/common.pro
+@@ -126,6 +126,8 @@ SOURCES += filterparameter.cpp \
+ #win32-msvc2008:LIBS += ../external/lib/win32-msvc2008/jhead.lib
+ #win32-msvc2010:LIBS += ../external/lib/win32-msvc2010/jhead.lib
+ #win32-msvc2012:LIBS += ../external/lib/win32-msvc2012/jhead.lib
+
+CONFIG += static
+ #win32-g++:LIBS += -L../external/lib/win32-gcc -ljhead
+ #linux-g++:LIBS += -L../external/lib/linux-g++ -ljhead
+ #linux-g++-32:LIBS += -L../external/lib/linux-g++-32 -ljhead
diff --git a/cad/qcad/files/patch-src_core_RS.cpp b/cad/qcad/files/patch-src_core_RS.cpp
index 9663a39262db..2238fc4983c8 100644
--- a/cad/qcad/files/patch-src_core_RS.cpp
+++ b/cad/qcad/files/patch-src_core_RS.cpp
@@ -1,11 +1,13 @@
---- src/core/RS.cpp.orig 2015-01-30 18:11:57.235513076 +0100
-+++ src/core/RS.cpp 2015-01-30 18:12:23.988630795 +0100
-@@ -119,4 +119,8 @@
- */
+--- src/core/RS.cpp.orig 2017-07-21 17:57:53 UTC
++++ src/core/RS.cpp
+@@ -118,6 +118,10 @@ QStringList RS::getDirectoryList(const Q
+ }
+ #ifdef Q_OS_MAC
+#ifdef Q_OS_FREEBSD
+ dirList.append("%%DATADIR%%/" + subDirectory);
+#endif
+
- // Individual directories:
- /*
+ // Mac OS X app bundle:
+ dirList.append(appDir + "/../Resources/" + subDirectory);
+ dirList.append(appDir + "/../../../" + subDirectory);
diff --git a/databases/postgresql-libpqxx3/files/patch-svn_1833 b/databases/postgresql-libpqxx3/files/patch-svn_1833
index 58c1bc3b3644..5c51da50f243 100644
--- a/databases/postgresql-libpqxx3/files/patch-svn_1833
+++ b/databases/postgresql-libpqxx3/files/patch-svn_1833
@@ -1,42 +1,51 @@
---- include/pqxx/largeobject.hxx (revision 1706)
-+++ include/pqxx/largeobject.hxx (revision 1833)
-@@ -397,5 +397,5 @@
+--- ChangeLog.orig 2013-01-17 07:25:02 UTC
++++ ChangeLog
+@@ -1,3 +1,8 @@
++2012-08-03 Jeroen T. Vermeulen <jtv@xs4all.nl>
++ include/pqxx/largeobject.hxx:
++ - Backported fix for #252: clang++ 3.2 compile error. Thanks Amy Troschinetz.
++ src/strconv.cxx:
++ - Backported fix for #253: clang++ 3.2 compile error. Thanks Amy Troschinetz.
+ 2013-01-17 Jeroen T. Vermeulen <jtv@xs4all.nl>
+ tools/splitconfig:
+ - Rewrote in python.
+--- include/pqxx/largeobject.hxx.orig 2013-01-17 07:25:00 UTC
++++ include/pqxx/largeobject.hxx
+@@ -396,7 +396,7 @@ public:
+ openmode mode = PGSTD::ios::in | PGSTD::ios::out,
size_type BufSize=512) : //[t48]
m_BufSize(BufSize),
- m_Obj(T, O),
+ m_Obj(T, O, mode),
m_G(0),
m_P(0)
-@@ -407,5 +407,5 @@
+ { initialize(mode); }
+@@ -406,7 +406,7 @@ public:
+ openmode mode = PGSTD::ios::in | PGSTD::ios::out,
size_type BufSize=512) : //[t48]
m_BufSize(BufSize),
- m_Obj(T, O),
+ m_Obj(T, O, mode),
m_G(0),
m_P(0)
---- ChangeLog (revision 1825)
-+++ ChangeLog (revision 1833)
-@@ -1,2 +1,7 @@
-+2012-08-03 Jeroen T. Vermeulen <jtv@xs4all.nl>
-+ include/pqxx/largeobject.hxx:
-+ - Backported fix for #252: clang++ 3.2 compile error. Thanks Amy Troschinetz.
-+ src/strconv.cxx:
-+ - Backported fix for #253: clang++ 3.2 compile error. Thanks Amy Troschinetz.
- 2012-03-25 Jeroen T. Vermeulen <jtv@xs4all.nl>
- test/test002.cxx, test/test007.cxx, test/test011.cxx, test/test012.cxx,
---- src/strconv.cxx (revision 1724)
-+++ src/strconv.cxx (revision 1833)
-@@ -7,5 +7,5 @@
+ { initialize(mode); }
+--- src/strconv.cxx.orig 2013-01-17 07:25:01 UTC
++++ src/strconv.cxx
+@@ -6,7 +6,7 @@
+ * DESCRIPTION
* implementation of string conversions
*
- * Copyright (c) 2008, Jeroen T. Vermeulen <jtv@xs4all.nl>
+ * Copyright (c) 2008-2012, Jeroen T. Vermeulen <jtv@xs4all.nl>
*
* See COPYING for copyright license. If you did not receive a file called
-@@ -193,5 +193,5 @@
+ * COPYING with this source code, please notify the distributor of this mistake,
+@@ -230,7 +230,7 @@ template<typename T> inline void from_st
+ #if defined(PQXX_HAVE_IMBUE)
S.imbue(locale("C"));
#endif
- ok = (S >> result);
+ ok = static_cast<bool>(S >> result);
}
break;
+ }
diff --git a/emulators/pcsxr/files/patch-pixmaps-Makefile.am b/emulators/pcsxr/files/patch-pixmaps-Makefile.am
deleted file mode 100644
index ec7c400ef7ea..000000000000
--- a/emulators/pcsxr/files/patch-pixmaps-Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
---- pixmaps/Makefile.am.orig 2010-05-26 05:59:40.935976220 +0000
-+++ pixmaps/Makefile.am 2010-05-26 05:59:52.223938796 +0000
-@@ -1,4 +1,4 @@
--pixmapdir = "$(datadir)/pcsx"
-+pixmapdir = "$(datadir)/pcsxr"
- pixmap_DATA = pcsx.jpg
-
- icondir = "$(datadir)/pixmaps"
diff --git a/games/blockout/Makefile b/games/blockout/Makefile
index 0490110f8a09..55c7ceaecb8e 100644
--- a/games/blockout/Makefile
+++ b/games/blockout/Makefile
@@ -18,8 +18,9 @@ ONLY_FOR_ARCHS= i386 amd64
USE_SDL= mixer sdl
USES= gmake dos2unix
-DOS2UNIX_FILES= ${WRKSRC}/ImageLib/src/gif/gif.h \
- ${WRKSRC}/ImageLib/src/gif/gif.cpp ${WRKSRC}/BlockOut/*.cpp
+DOS2UNIX_FILES= ImageLib/src/gif/gif.h \
+ ImageLib/src/gif/gif.cpp BlockOut/*.cpp \
+ ImageLib/src/png/hpng.c
USE_GL= gl glu
WRKSRC= ${WRKDIR}/BL_SRC
diff --git a/graphics/dia/files/patch-app_main.c b/graphics/dia/files/patch-app_main.c
index aca97ced24ad..d105c04a6f64 100644
--- a/graphics/dia/files/patch-app_main.c
+++ b/graphics/dia/files/patch-app_main.c
@@ -1,12 +1,19 @@
---- app/main.c.orig Sun Mar 25 19:05:16 2001
-+++ app/main.c Thu May 17 14:09:02 2001
-@@ -19,2 +19,4 @@
+--- app/main.c.orig 2014-08-24 15:44:07 UTC
++++ app/main.c
+@@ -17,12 +17,16 @@
+ */
+ #include <config.h>
+#include <ieeefp.h>
+
- #include "geometry.h"
-@@ -35,2 +37,4 @@
+ #include "app_procs.h"
+
+ #include "interface.h"
+
+ int main(int argc, char *argv[])
{
+ fpsetmask(0);
+
app_init(argc, argv);
+
+ if (!app_is_interactive())
diff --git a/graphics/dia/files/patch-doc_fr_Makefile.in b/graphics/dia/files/patch-doc_fr_Makefile.in
index a2eb3fcb9033..63e310ded944 100644
--- a/graphics/dia/files/patch-doc_fr_Makefile.in
+++ b/graphics/dia/files/patch-doc_fr_Makefile.in
@@ -1,6 +1,6 @@
---- doc/fr/Makefile.in.orig
+--- doc/fr/Makefile.in.orig 2014-09-05 15:08:04 UTC
+++ doc/fr/Makefile.in
-@@ -285,7 +285,7 @@
+@@ -389,7 +389,7 @@ libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
diff --git a/www/domoticz/files/patch-appversion.default b/www/domoticz/files/patch-appversion.default
index 3fcc831cdc1b..b8808f28b3fa 100644
--- a/www/domoticz/files/patch-appversion.default
+++ b/www/domoticz/files/patch-appversion.default
@@ -1,9 +1,9 @@
---- appversion.default.orig 2016-03-09 17:30:00.000000000 +0100
-+++ appversion.default 2016-03-09 19:10:01.169567000 +0100
+--- appversion.default.orig 2017-07-30 10:19:41 UTC
++++ appversion.default
@@ -1,3 +1,3 @@
--#define APPVERSION 4834
--#define APPHASH "2bd98a1"
--#define APPDATE 1456904172
+-#define APPVERSION 5876
+-#define APPHASH "b97777b"
+-#define APPDATE 1478691222
+#define APPVERSION XXXDOMOTICZXXX
+#define APPHASH "XXXHASHXXX"
+#define APPDATE XXXTIMEXXX
diff --git a/x11-themes/murrine-configurator/files/patch-files__murrine-configurator b/x11-themes/murrine-configurator/files/patch-files__murrine-configurator
index d4d1588d2ea7..4281339086a1 100644
--- a/x11-themes/murrine-configurator/files/patch-files__murrine-configurator
+++ b/x11-themes/murrine-configurator/files/patch-files__murrine-configurator
@@ -1,5 +1,8 @@
---- files/murrine-configurator.orig
+--- files/murrine-configurator.orig 2007-01-02 19:39:31 UTC
+++ files/murrine-configurator
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/local/bin/bash
+ # License GPL
+ # By Cimi & Tome
+
diff --git a/x11-toolkits/hs-wx/Makefile b/x11-toolkits/hs-wx/Makefile
index 1b3fb5d268db..b1e8c94ca6cc 100644
--- a/x11-toolkits/hs-wx/Makefile
+++ b/x11-toolkits/hs-wx/Makefile
@@ -7,7 +7,9 @@ CATEGORIES= x11-toolkits haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= wxHaskell
+USES= dos2unix
USE_CABAL= stm wxcore>=0.91
+DOS2UNIX_FILES= src/Graphics/UI/WX/Window.hs
USE_WX= 3.0
WX_COMPS= wx
diff --git a/x11-toolkits/hs-wx/files/patch-src_Graphics_UI_WX_Window.hs b/x11-toolkits/hs-wx/files/patch-src_Graphics_UI_WX_Window.hs
index 74bf20e9c657..c0e3bef2569c 100644
--- a/x11-toolkits/hs-wx/files/patch-src_Graphics_UI_WX_Window.hs
+++ b/x11-toolkits/hs-wx/files/patch-src_Graphics_UI_WX_Window.hs
@@ -1,8 +1,8 @@
---- src/Graphics/UI/WX/Window.hs.orig 2014-08-11 14:58:24 UTC
+--- src/Graphics/UI/WX/Window.hs.orig 2017-11-09 22:05:23 UTC
+++ src/Graphics/UI/WX/Window.hs
@@ -1,4 +1,4 @@
--{-# LANGUAGE TypeSynonymInstances, FlexibleInstances #-}
+-{-# LANGUAGE FlexibleContexts #-}
+{-# LANGUAGE TypeSynonymInstances, FlexibleInstances, FlexibleContexts #-}
+ {-# LANGUAGE FlexibleInstances #-}
+ {-# LANGUAGE TypeSynonymInstances #-}
--------------------------------------------------------------------------------
- {-| Module : Window
- Copyright : (c) Daan Leijen 2003