aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-08 06:12:42 +0800
committermiwi <miwi@FreeBSD.org>2009-01-08 06:12:42 +0800
commit0811fd8ad9de02740d476238b6632b14e138d347 (patch)
tree7001551c40c2bf429b853097b81e1b1aa64e52ca
parentb7097002bfd867a8fbfd0b7949a43b4fc2952c43 (diff)
downloadfreebsd-ports-gnome-0811fd8ad9de02740d476238b6632b14e138d347.tar.gz
freebsd-ports-gnome-0811fd8ad9de02740d476238b6632b14e138d347.tar.zst
freebsd-ports-gnome-0811fd8ad9de02740d476238b6632b14e138d347.zip
GBirthday is a birthday reminder application that helps you to remember your
evolution contacts' birthdays. It puts an icon on notification area which will blink when there is any of your contacts' birthday today. You can also check if there is any of your contacs' birhday on next days. WWW: http://gbirthday.sourceforge.net/ PR: ports/130091 Submitted by: Alexander Logvinov <ports at logvinov.com>
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/gbirthday/Makefile38
-rw-r--r--deskutils/gbirthday/distinfo3
-rw-r--r--deskutils/gbirthday/files/patch-gbirthday.desktop17
-rw-r--r--deskutils/gbirthday/files/patch-languages_ru.lang24
-rw-r--r--deskutils/gbirthday/pkg-descr6
-rw-r--r--deskutils/gbirthday/pkg-plist26
7 files changed, 115 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 346af736328e..3ac220afd329 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -64,6 +64,7 @@
SUBDIR += gaddr
SUBDIR += ganttproject
SUBDIR += ganyremote
+ SUBDIR += gbirthday
SUBDIR += gcal
SUBDIR += gcalcli
SUBDIR += gdesklets
diff --git a/deskutils/gbirthday/Makefile b/deskutils/gbirthday/Makefile
new file mode 100644
index 000000000000..3b88adf594aa
--- /dev/null
+++ b/deskutils/gbirthday/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gbirthday
+# Date created: 01 January 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gbirthday
+PORTVERSION= 0.4.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= SF
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A birthday reminder for Evolution contacts
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PYTHON_RUN= yes
+USE_GNOME= pygtk2 evolutiondataserver
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/${PORTNAME}|${DATADIR}|g' \
+ ${WRKSRC}/${PORTNAME}.py ${WRKSRC}/${PORTNAME}.desktop
+ @${RM} ${WRKSRC}/languages/*.orig
+
+do-install:
+.for dir in pics languages
+ @${MKDIR} ${DATADIR}/${dir}
+ ${INSTALL_DATA} ${WRKSRC}/${dir}/* ${DATADIR}/${dir}/
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${DATADIR}
+ ${LN} -fs ${DATADIR}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
+
+.include <bsd.port.mk>
diff --git a/deskutils/gbirthday/distinfo b/deskutils/gbirthday/distinfo
new file mode 100644
index 000000000000..8a36183e40ac
--- /dev/null
+++ b/deskutils/gbirthday/distinfo
@@ -0,0 +1,3 @@
+MD5 (gbirthday-0.4.1.tar.gz) = d2a028ab886d05702152386e6e2978c7
+SHA256 (gbirthday-0.4.1.tar.gz) = 22094bc69a0ab1490875988bd485ac07be8eeab436d394ec2e0d5250f4ca12ff
+SIZE (gbirthday-0.4.1.tar.gz) = 38572
diff --git a/deskutils/gbirthday/files/patch-gbirthday.desktop b/deskutils/gbirthday/files/patch-gbirthday.desktop
new file mode 100644
index 000000000000..c0f93454b1be
--- /dev/null
+++ b/deskutils/gbirthday/files/patch-gbirthday.desktop
@@ -0,0 +1,17 @@
+--- gbirthday.desktop.orig 2007-11-21 08:25:22.000000000 +0900
++++ gbirthday.desktop 2009-01-01 19:22:13.000000000 +0900
+@@ -1,5 +1,6 @@
+ [Desktop Entry]
+ Name=GBirthday
++Name[ru]=Напоминание о Днях рождения GBirthday
+ Version=0.4.0
+ Comment=Birthday reminder for Evolution contacts
+ Comment[en]=Birthday reminder for Evolution contacts
+@@ -9,6 +10,7 @@
+ Comment[gl]=Recordatorio de aniversarios pros contactos do Evolution
+ Comment[it]=Promemoria compleanno per i contatti di Evolution
+ Comment[pt]=Lembrete dos aniversários para os contatos do Evolution
++Comment[ru]=Напоминание о Днях рождения для контактов Evolution
+ Comment[sk]=Upozornenie na narodeniny pre kontakty programu Evolution
+ Exec=gbirthday
+ Terminal=false
diff --git a/deskutils/gbirthday/files/patch-languages_ru.lang b/deskutils/gbirthday/files/patch-languages_ru.lang
new file mode 100644
index 000000000000..4f74303f9580
--- /dev/null
+++ b/deskutils/gbirthday/files/patch-languages_ru.lang
@@ -0,0 +1,24 @@
+--- languages/ru.lang 2009-01-01 18:35:18.000000000 +0900
++++ languages/ru.lang 2009-01-01 18:33:20.000000000 +0900
+@@ -0,0 +1,21 @@
++about_language=Русский перевод
++about_translation=Alexander Logvinov
++about_comments=Напоминание о Днях рождения для контактов Evolution
++menu_reload=Загрузить данные
++menu_blink=Остановить индикацию
++menu_preferences=Настройки
++menu_about=О программе
++menu_quit=Выход
++pref_past=Предыдущие Дни рождения
++pref_next=Следующие Дни рождения
++pref_button=Сохранить и выйти
++pos_month=2
++pos_day=1
++txt_birthday=Дни рождения
++txt_empty=В указанном периоде Дней рождения нет
++txt_today=Сегодня
++txt_yesterday=Вчера
++txt_daysago=### дня(ей) назад
++txt_tomorrow=Завтра
++txt_days=дня(ей)
++txt_years=лет
diff --git a/deskutils/gbirthday/pkg-descr b/deskutils/gbirthday/pkg-descr
new file mode 100644
index 000000000000..b7e0dd13a37e
--- /dev/null
+++ b/deskutils/gbirthday/pkg-descr
@@ -0,0 +1,6 @@
+GBirthday is a birthday reminder application that helps you to remember your
+evolution contacts' birthdays. It puts an icon on notification area which will
+blink when there is any of your contacts' birthday today. You can also check if
+there is any of your contacs' birhday on next days.
+
+WWW: http://gbirthday.sourceforge.net/
diff --git a/deskutils/gbirthday/pkg-plist b/deskutils/gbirthday/pkg-plist
new file mode 100644
index 000000000000..74bfda12d174
--- /dev/null
+++ b/deskutils/gbirthday/pkg-plist
@@ -0,0 +1,26 @@
+bin/gbirthday
+share/applications/gbirthday.desktop
+%%DATADIR%%/gbirthday.py
+%%DATADIR%%/languages/de.lang
+%%DATADIR%%/languages/en.lang
+%%DATADIR%%/languages/es.lang
+%%DATADIR%%/languages/es_AR.lang
+%%DATADIR%%/languages/es_ES.lang
+%%DATADIR%%/languages/fr.lang
+%%DATADIR%%/languages/gl.lang
+%%DATADIR%%/languages/it.lang
+%%DATADIR%%/languages/ru.lang
+%%DATADIR%%/languages/pt.lang
+%%DATADIR%%/languages/sk.lang
+%%DATADIR%%/pics/birthday.png
+%%DATADIR%%/pics/birthdaylost.png
+%%DATADIR%%/pics/birthdaynext.png
+%%DATADIR%%/pics/birthdaytoday.png
+%%DATADIR%%/pics/gbirthday.png
+%%DATADIR%%/pics/gbirthday.svg
+%%DATADIR%%/pics/nobirthday.png
+%%DATADIR%%/pics/pie.svg
+@dirrmtry %%DATADIR%%/languages
+@dirrmtry %%DATADIR%%/pics
+@dirrmtry %%DATADIR%%
+@dirrmtry share/applications