aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmelo <jmelo@FreeBSD.org>2007-07-10 03:10:26 +0800
committerjmelo <jmelo@FreeBSD.org>2007-07-10 03:10:26 +0800
commit08df8e7f189673c1652f3ff096aa3c52b317d0ba (patch)
tree4eb449379023d92217734687dc6b547b173c32c1
parent603616889bdbff29f9506ec6764a4cc5e4d1ab60 (diff)
downloadfreebsd-ports-gnome-08df8e7f189673c1652f3ff096aa3c52b317d0ba.tar.gz
freebsd-ports-gnome-08df8e7f189673c1652f3ff096aa3c52b317d0ba.tar.zst
freebsd-ports-gnome-08df8e7f189673c1652f3ff096aa3c52b317d0ba.zip
- Fix mastersite.
- Remove /usr/local from ut-bin binary. PR: ports/113934 Submitted by: Sean Farley <sean-freebsd@farley.org> (maintainer)
-rw-r--r--games/linux-ut/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/games/linux-ut/Makefile b/games/linux-ut/Makefile
index 618b962b676e..c7022b036547 100644
--- a/games/linux-ut/Makefile
+++ b/games/linux-ut/Makefile
@@ -8,7 +8,7 @@
PORTNAME= linux-ut
PORTVERSION= 451
CATEGORIES= games linux
-MASTER_SITES= http://liflg.0wnitsch.de/files/native/:p436 \
+MASTER_SITES= http://liflg.0wnitsch.de/files/final/:p436 \
http://www.utpg.org/patches/:p451
DISTFILES= ${PATCH436FILES} \
${PATCH451FILES}
@@ -112,6 +112,13 @@ do-install:
${MV} -f galaxy.int Galaxy.int &&\
${MV} -f editor.int Editor.int &&\
${MV} -f windrv.int WinDrv.int
+ @${ECHO_CMD} "Removing /usr/local from ut-bin's library search path"
+ @UTBIN=${DATADIR}/System/ut-bin &&\
+ FILESIZE=`/usr/bin/stat -f "%z" $${UTBIN}` &&\
+ ${MV} $${UTBIN} $${UTBIN}.orig &&\
+ ${SED} -Ee 's|:/usr/local|:/USR-LOCAL|' $${UTBIN}.orig |\
+ ${HEAD} -c $${FILESIZE} > $${UTBIN} &&\
+ ${RM} $${UTBIN}.orig
@${ECHO_CMD} "Setting permissions"
@${FIND} ${DATADIR} -print0 |\
${XARGS} -0 ${CHOWN} ${SHAREOWN}:${SHAREGRP}