aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2012-01-03 01:06:34 +0800
committerstephen <stephen@FreeBSD.org>2012-01-03 01:06:34 +0800
commit0afb9e6f7e36af5804ac85f263cf309ebf5cb36b (patch)
treed3c1906c366bf3b76341f9b793e2a51904dbc5fe
parentf9278b67d83b0dcf3b16befc6df5d430724d0c37 (diff)
downloadfreebsd-ports-gnome-0afb9e6f7e36af5804ac85f263cf309ebf5cb36b.tar.gz
freebsd-ports-gnome-0afb9e6f7e36af5804ac85f263cf309ebf5cb36b.tar.zst
freebsd-ports-gnome-0afb9e6f7e36af5804ac85f263cf309ebf5cb36b.zip
- Accommodate upgrade of major version of devel/gdcm from 2.0 to 2.2.
- Bump port revision.
-rw-r--r--math/octave-forge-dicom/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/math/octave-forge-dicom/Makefile b/math/octave-forge-dicom/Makefile
index f6de4d152b56..736b4b61d0d3 100644
--- a/math/octave-forge-dicom/Makefile
+++ b/math/octave-forge-dicom/Makefile
@@ -7,14 +7,13 @@
PORTNAME= octave-forge-dicom
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-#LIB_DEPENDS+= gdcmCommon:${PORTSDIR}/devel/gdcm
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libgdcmCommon.so:${PORTSDIR}/devel/gdcm
-RUN_DEPENDS+= ${LOCALBASE}/lib/libgdcmCommon.so:${PORTSDIR}/devel/gdcm
+LIB_DEPENDS+= gdcmCommon:${PORTSDIR}/devel/gdcm
# OCTSRC is the name of the directory of the package.
# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
@@ -22,6 +21,13 @@ OCTSRC= ${OCTAVE_PKGNAME}
WRKSRC= ${WRKDIR}/${OCTSRC}/src
+GDCM_MAJ= 2.2
+post-patch:
+ ${REINPLACE_CMD} s/gdcm-2.0/gdcm-${GDCM_MAJ}/ \
+ ${WRKSRC}/dicominfo.cpp ${WRKSRC}/dicomdict.cpp \
+ ${WRKSRC}/dicomread.cpp ${WRKSRC}/dicomlookup.cpp \
+ ${WRKSRC}/_gendicomdict.cpp ${WRKSRC}/dicomwrite.cpp
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"