aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-11 14:34:23 +0800
committerbapt <bapt@FreeBSD.org>2013-07-11 14:34:23 +0800
commit0c3881a18539f867d366fa99c0b5e7aea8460cba (patch)
treea527f4a695ce48c1917ff9f8191134be87a3ee02
parentcfc652a0033750190983fdd07328726f0101f2fb (diff)
downloadfreebsd-ports-gnome-0c3881a18539f867d366fa99c0b5e7aea8460cba.tar.gz
freebsd-ports-gnome-0c3881a18539f867d366fa99c0b5e7aea8460cba.tar.zst
freebsd-ports-gnome-0c3881a18539f867d366fa99c0b5e7aea8460cba.zip
Use USES=display:build instead of custom implementation
-rw-r--r--math/scilab-toolbox-swt/Makefile23
1 files changed, 2 insertions, 21 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index 130406ca4d11..06ef2a518414 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -1,9 +1,5 @@
-## New ports collection makefile for: swt
-# Date created: 2006-03-28
-# Whom: Max Brazhnikov makc@issp.ac.ru
-#
+# Created by: Max Brazhnikov makc@issp.ac.ru
# $FreeBSD$
-#
PORTNAME= swt
PORTVERSION= 0.1.11
@@ -43,7 +39,7 @@ SCILAB_ARGS= -nogui
PLIST_SUB+= HELP="@comment "
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-etc__swt.start
.else
-USE_DISPLAY= yes
+USES= display:build
MAKE_ENV= LC_ALL="C"
PLIST_SUB+= HELP=""
TOOLBOX_SUBDIRS+= jar
@@ -59,27 +55,12 @@ post-patch:
pre-build:
${FIND} -d ${WRKSRC} \( -name '*.orig' -or -name '*.bak' \) -delete
-.if ${PORT_OPTIONS:MHELP} && !defined(DISPLAY)
- @if [ -f ${WRKDIR}/.Xvfb.pid ]; then \
- ${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill || ${TRUE} ; \
- ${RM} -f ${WRKDIR}/.Xvfb.pid ; \
- fi
- ${LOCALBASE}/bin/Xvfb :1001 -screen 0 800x600x24 -fp ${LOCALBASE}/lib/X11/fonts/misc > /dev/null 2>&1 & ${ECHO} $$! > ${WRKDIR}/.Xvfb.pid
- @sleep 5
.endif
do-build:
cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${SCILAB_CMD} ${SCILAB_ARGS} -f builder.sce
-post-build:
-.if ${PORT_OPTIONS:MHELP} && !defined(DISPLAY)
- @if [ -f ${WRKDIR}/.Xvfb.pid ]; then \
- ${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill || ${TRUE} ; \
- ${RM} -f ${WRKDIR}/.Xvfb.pid ; \
- fi
-.endif
-
do-install:
${MKDIR} ${TOOLBOXDIR}/sci_gateway/c
${INSTALL_DATA} ${WRKSRC}/loader.sce ${TOOLBOXDIR}