aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-24 13:47:16 +0800
committerbapt <bapt@FreeBSD.org>2013-05-24 13:47:16 +0800
commit0c8748e290645767cfa33839e6f3cfea3ef4de3f (patch)
treeeb68178a04420b7c366f975f050048fcb458ddc4
parent7f7b8800c3e3ad2cbfa26445e5fb2de93519c86e (diff)
downloadfreebsd-ports-gnome-0c8748e290645767cfa33839e6f3cfea3ef4de3f.tar.gz
freebsd-ports-gnome-0c8748e290645767cfa33839e6f3cfea3ef4de3f.tar.zst
freebsd-ports-gnome-0c8748e290645767cfa33839e6f3cfea3ef4de3f.zip
Convert to new options framework
While here add missing dependency on pkgconf
-rw-r--r--mail/rspamd/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/mail/rspamd/Makefile b/mail/rspamd/Makefile
index 659692267c7c..d4840be71a1a 100644
--- a/mail/rspamd/Makefile
+++ b/mail/rspamd/Makefile
@@ -14,9 +14,10 @@ LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
gmime-2.0:${PORTSDIR}/mail/gmime2 \
event-1.4:${PORTSDIR}/devel/libevent
-OPTIONS= RSPAMD_GPERF "Enable google perf-tools profiling" off \
- RSPAMD_JUDY "Enable Judy arrays usage for performance" off \
- RSPAMD_REDIRECTOR "Install HTTP redirector" off
+OPTIONS_DEFINE= GPERF JUDY REDIRECTOR
+GPERF_DESC= google perf-tools profiling
+JUDY_DESC= Judy arrays usage for performance
+REDIRECTOR_DESC= Install HTTP redirector
USE_RC_SUBR= rspamd
@@ -25,7 +26,7 @@ PLIST_SUB+= ETCDIR=etc/rspamd \
CMAKE_ARGS+= -DETC_PREFIX=${PREFIX}/etc -DPREFIX=${PREFIX} \
-DBUILD_PORT=yes
-USES= cmake gettext iconv
+USES= cmake gettext iconv pkgconfig
USE_LDCONFIG= yes
USE_GNOME= glib20
@@ -36,18 +37,18 @@ USE_OPENSSL= yes
MAN8= rspamd.8
MAN1= rspamc.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_RSPAMD_GPERF)
+.if ${PORT_OPTIONS:MGPERF}
CMAKE_ARGS+= -DENABLE_GPERF_TOOLS=ON
LIB_DEPENDS+= profiler.1:${PORTSDIR}/devel/google-perftools
.endif
-.if defined(WITH_RSPAMD_JUDY)
+.if ${PORT_OPTIONS:MJUDY}
LIB_DEPENDS+= Judy:${PORTSDIR}/devel/judy
.endif
-.if defined(WITH_RSPAMD_REDIRECTOR)
+.if ${PORT_OPTIONS:MREDIRECTOR}
USE_PERL5= yes
CMAKE_ARGS+= -DENABLE_REDIRECTOR=ON
PLIST_SUB+= REDIRECTOR=""
@@ -68,4 +69,4 @@ MAN1= rspamc.1
PLIST_SUB+= REDIRECTOR="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>