aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-09-15 00:22:32 +0800
committersat <sat@FreeBSD.org>2006-09-15 00:22:32 +0800
commit0d59dc749c132393e38777c9684ab593345274a3 (patch)
treebcde2843218352526ff4806bb22f44b48ad29104
parent17c423b5f8eaef4440d8e5beaed868007d63bfec (diff)
downloadfreebsd-ports-gnome-0d59dc749c132393e38777c9684ab593345274a3.tar.gz
freebsd-ports-gnome-0d59dc749c132393e38777c9684ab593345274a3.tar.zst
freebsd-ports-gnome-0d59dc749c132393e38777c9684ab593345274a3.zip
Add port audio/libaiff:
LibAiff is a library for C applications, providing transparent read and write operations for Audio Interchange File Format files. With LibAiff your application can easily use the Audio IFF format to interchange digital audio. LibAiff wants to implement all the features of the AIFF 1.3 standard, including markers, comments, etc. This version of LibAiff supports the following features: * Reading any valid Audio IFF file. * Writing a valid Audio IFF file. * Reading a compressed AIFF Compressed (AIFC) file with audio encoded in Linear PCM, both big-endian and little-endian. * Read & write samples in all formats supported by the Audio IFF standard. * Convert any sample format to and from 32 bits. * Getting and setting all the AIFF Attributes. * Reading and writing markers to positions on the sound. * Reading instrument data from AIFF files. WWW: http://aifftools.sourceforge.net/libaiff/
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libaiff/Makefile25
-rw-r--r--audio/libaiff/distinfo3
-rw-r--r--audio/libaiff/pkg-descr22
4 files changed, 51 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 82a604b20580..cd5cacdb5291 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -292,6 +292,7 @@
SUBDIR += liba52
SUBDIR += liba52-devel
SUBDIR += libadplug
+ SUBDIR += libaiff
SUBDIR += libao
SUBDIR += libaudiofile
SUBDIR += libcdaudio
diff --git a/audio/libaiff/Makefile b/audio/libaiff/Makefile
new file mode 100644
index 000000000000..762a685a58d6
--- /dev/null
+++ b/audio/libaiff/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libaiff
+# Date created: 14 September 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libaiff
+PORTVERSION= 2.0
+CATEGORIES= audio
+MASTER_SITES= SF/aifftools
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Read and write AIFF files
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/${PORTNAME}.a include/${PORTNAME}/config.h include/${PORTNAME}/endian.h \
+ include/${PORTNAME}/${PORTNAME}.h
+PLIST_DIRS= include/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/install: libaiff.a/install:/' ${WRKSRC}/${MAKEFILE}.in
+
+.include <bsd.port.mk>
diff --git a/audio/libaiff/distinfo b/audio/libaiff/distinfo
new file mode 100644
index 000000000000..4684b1f7e4c7
--- /dev/null
+++ b/audio/libaiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (libaiff-2.0.tar.gz) = 90efe14098d85459b3fb303ad56ec0d4
+SHA256 (libaiff-2.0.tar.gz) = 17763395f99a6fed1e3ff9521ffe7633459aa9119642d6f3dcf8c560b69a59e5
+SIZE (libaiff-2.0.tar.gz) = 55429
diff --git a/audio/libaiff/pkg-descr b/audio/libaiff/pkg-descr
new file mode 100644
index 000000000000..f80c9be540bb
--- /dev/null
+++ b/audio/libaiff/pkg-descr
@@ -0,0 +1,22 @@
+LibAiff is a library for C applications, providing transparent read and
+write operations for Audio Interchange File Format files.
+
+With LibAiff your application can easily use the Audio IFF format to
+interchange digital audio.
+
+LibAiff wants to implement all the features of the AIFF 1.3 standard,
+including markers, comments, etc.
+
+This version of LibAiff supports the following features:
+
+ * Reading any valid Audio IFF file.
+ * Writing a valid Audio IFF file.
+ * Reading a compressed AIFF Compressed (AIFC) file with audio encoded
+ in Linear PCM, both big-endian and little-endian.
+ * Read & write samples in all formats supported by the Audio IFF standard.
+ * Convert any sample format to and from 32 bits.
+ * Getting and setting all the AIFF Attributes.
+ * Reading and writing markers to positions on the sound.
+ * Reading instrument data from AIFF files.
+
+WWW: http://aifftools.sourceforge.net/libaiff/