aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-03 00:02:58 +0800
committermiwi <miwi@FreeBSD.org>2014-02-03 00:02:58 +0800
commit0facf53f85bb3d9dcbfe491912db80a50c11f760 (patch)
treee2df981d19fd0eedb0234e122c27be35b4f92540
parent4ee6bd76e29fead113bf6f0ce67c66cc68974734 (diff)
downloadfreebsd-ports-gnome-0facf53f85bb3d9dcbfe491912db80a50c11f760.tar.gz
freebsd-ports-gnome-0facf53f85bb3d9dcbfe491912db80a50c11f760.tar.zst
freebsd-ports-gnome-0facf53f85bb3d9dcbfe491912db80a50c11f760.zip
- Stage support
-rw-r--r--mail/milter-skem/Makefile7
-rw-r--r--mail/pfqueue/Makefile4
-rw-r--r--mail/pfqueue/pkg-plist2
-rw-r--r--x11/nvidia-xconfig/Makefile8
4 files changed, 7 insertions, 14 deletions
diff --git a/mail/milter-skem/Makefile b/mail/milter-skem/Makefile
index 393d6c35d13e..3123b77b3bb4 100644
--- a/mail/milter-skem/Makefile
+++ b/mail/milter-skem/Makefile
@@ -11,9 +11,8 @@ COMMENT= Cache earlier sendmail's verdicts for the relays
USE_BZIP2= yes
-PLIST_FILES= sbin/skem
-MAN8= skem.8
-MANCOMPRESSED= maybe
+PLIST_FILES= sbin/skem \
+ man/man8/skem.8.gz
OPTIONS_DEFINE= SKEM_MILTER421 SKEM_NO_CLEANUP SKEM_NO_LOGWATCHER SKEM_NETINET6 SKEM_NETINET
SKEM_MILTER421_DESC= Sendmail was built with -D_FFR_MILTER_421
@@ -24,8 +23,6 @@ SKEM_NETINET_DESC= Support IPv4 addresses
OPTIONS_DEFAULT= SKEM_NETINET
-
-NO_STAGE= yes
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/mail/pfqueue/Makefile b/mail/pfqueue/Makefile
index 332b3d4cb5e7..bb190576cdb0 100644
--- a/mail/pfqueue/Makefile
+++ b/mail/pfqueue/Makefile
@@ -14,10 +14,6 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= ${PTHREAD_CFLAGS}
-MAN1= pfqueue.1
-MAN5= pfqueue.conf.5
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|-lc_r|${PTHREAD_LIBS}|g" \
-e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
diff --git a/mail/pfqueue/pkg-plist b/mail/pfqueue/pkg-plist
index db52e1ee880f..d7d9d02f81f9 100644
--- a/mail/pfqueue/pkg-plist
+++ b/mail/pfqueue/pkg-plist
@@ -20,3 +20,5 @@ lib/libpfqueue.a
lib/libpfqueue.la
lib/libpfqueue.so
lib/libpfqueue.so.0
+man/man1/pfqueue.1.gz
+man/man5/pfqueue.conf.5.gz
diff --git a/x11/nvidia-xconfig/Makefile b/x11/nvidia-xconfig/Makefile
index 0c85fb5f55b4..ccc52035c01e 100644
--- a/x11/nvidia-xconfig/Makefile
+++ b/x11/nvidia-xconfig/Makefile
@@ -13,7 +13,7 @@ COMMENT= Tool to manipulate X configuration files for the NVidia driver
LICENSE= GPLv2
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= NV_VERBOSE= \
STRIP_CMD=${TRUE} \
@@ -21,13 +21,11 @@ MAKE_ENV= NV_VERBOSE= \
INSTALL_MAN="${INSTALL_MAN}" \
prefix=${PREFIX}
-PLIST_FILES= bin/nvidia-xconfig
-MANCOMPRESSED= yes
-MAN1= nvidia-xconfig.1
+PLIST_FILES= bin/nvidia-xconfig \
+ man/man1/nvidia-xconfig.1.gz
post-patch: .SILENT
${REINPLACE_CMD} -e '/^prefix/s/=/?&/' \
-e '/^MANDIR/s|share/||' ${WRKSRC}/utils.mk
-NO_STAGE= yes
.include <bsd.port.mk>