aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2012-11-13 04:32:17 +0800
committerwxs <wxs@FreeBSD.org>2012-11-13 04:32:17 +0800
commit10bdae4398574189bb26c1354ebf4b07f498e29e (patch)
tree762981c484b26528e1cd87b2c1ab672d6e96d04b
parente54956e71afbe3c368f2fc6db00b11c18418e218 (diff)
downloadfreebsd-ports-gnome-10bdae4398574189bb26c1354ebf4b07f498e29e.tar.gz
freebsd-ports-gnome-10bdae4398574189bb26c1354ebf4b07f498e29e.tar.zst
freebsd-ports-gnome-10bdae4398574189bb26c1354ebf4b07f498e29e.zip
Add git_daemon to UIDs and GIDs.
Make git_daemon run as the git_daemon user. Requested by: lme@ Feature safe: yes
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--devel/git/Makefile3
-rw-r--r--devel/git/files/git_daemon.in6
4 files changed, 9 insertions, 2 deletions
diff --git a/GIDs b/GIDs
index fc3ff95a0ab6..8251e2eae241 100644
--- a/GIDs
+++ b/GIDs
@@ -243,5 +243,6 @@ trytond:*:960:
gearmand:*:961:
zookeeper:*:962:
fluentd:*:963:
+git_daemon:*:964:
nogroup:*:65533:
nobody:*:65534:
diff --git a/UIDs b/UIDs
index 02c9cbd78567..89823932d6f7 100644
--- a/UIDs
+++ b/UIDs
@@ -247,4 +247,5 @@ trytond:*:960:960::0:0:trytond daemon:/var/empty:/usr/sbin/nologin
gearmand:*:961:961::0:0:gearmand daemon:/var/empty:/usr/sbin/nologin
zookeeper:*:962:962::0:0:zookeeper user:/nonexistent:/usr/sbin/nologin
fluentd:*:963:963::0:0:fluentd user:/nonexistent:/usr/sbin/nologin
+git_daemon:*:964:964::0:0:git daemon:/nonexistent:/usr/sbin/nologin
nobody:*:65534:65534::0:0:Unprivileged user:/nonexistent:/usr/sbin/nologin
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 37d5353b8ea2..f2b47d1fad86 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -184,6 +184,9 @@ MAN7= gitcli.7 \
CONFLICTS?= git-subversion-[0-9]*
+USERS= git_daemon
+GROUPS= git_daemon
+
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/devel/git/files/git_daemon.in b/devel/git/files/git_daemon.in
index 778259469202..ce0fc0853989 100644
--- a/devel/git/files/git_daemon.in
+++ b/devel/git/files/git_daemon.in
@@ -15,13 +15,15 @@
. /etc/rc.subr
name="git_daemon"
-rcvar=git_daemon_enable
+rcvar="git_daemon_enable"
load_rc_config $name
+: ${git_daemon_user:=git_daemon}
+: ${git_daemon_group:=git_daemon}
: ${git_daemon_enable:=NO}
: ${git_daemon_directory:=%%PREFIX%%/git}
-: ${git_daemon_flags:="--syslog --reuseaddr --detach"}
+: ${git_daemon_flags:=--syslog --reuseaddr --detach}
command="%%PREFIX%%/libexec/git-core/git-daemon"
command_args="${git_daemon_directory}"