aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortom <tom@FreeBSD.org>2005-01-25 04:49:59 +0800
committertom <tom@FreeBSD.org>2005-01-25 04:49:59 +0800
commit12af9cad6a01106756ab2d7dc85710d670359118 (patch)
tree697d39886f18195453df19b942b742811ef9c672
parentf8cf8597140baacec7921d49412a6c1149386d3b (diff)
downloadfreebsd-ports-gnome-12af9cad6a01106756ab2d7dc85710d670359118.tar.gz
freebsd-ports-gnome-12af9cad6a01106756ab2d7dc85710d670359118.tar.zst
freebsd-ports-gnome-12af9cad6a01106756ab2d7dc85710d670359118.zip
Fix a few package list errors I introduced yesterday.
-rw-r--r--net/pppoa/Makefile6
-rw-r--r--net/pppoa/files/patch-doc-install27
-rw-r--r--net/pppoa/files/patch-src-install14
-rw-r--r--net/pppoa/pkg-plist3
4 files changed, 46 insertions, 4 deletions
diff --git a/net/pppoa/Makefile b/net/pppoa/Makefile
index f34b93333ead..df1679035925 100644
--- a/net/pppoa/Makefile
+++ b/net/pppoa/Makefile
@@ -28,7 +28,7 @@ RESTRICTED_FILES= ${ALCATELDRIVER}
WRKSRC= ${WRKDIR}/${SPEEDTOUCH}
-MAN1= modem_run.1 pppoa2.1 pppoa3.1
+MAN8= modem_run.8 pppoa2.8 pppoa3.8
USE_BZIP2= yes
.include <bsd.port.pre.mk>
@@ -37,6 +37,10 @@ post-extract:
@${TAR} -zxf ${DISTDIR}/${ALCATELDRIVER} -C ${WRKSRC}
@${REINPLACE_CMD} s/-lkse/${PTHREAD_LIBS}/g ${WRKSRC}/configure
+post-patch:
+ @${REINPLACE_CMD} 's/\@INSTALL_MAN\@/${INSTALL_MAN}/' \
+ ${WRKSRC}/doc-bsd/Makefile.in
+
post-install:
${INSTALL} -m 0755 -o root -g wheel -d ${PREFIX}/libdata
${INSTALL_DATA} ${WRKSRC}/mgmt/mgmt.o ${PREFIX}/libdata
diff --git a/net/pppoa/files/patch-doc-install b/net/pppoa/files/patch-doc-install
new file mode 100644
index 000000000000..6ec1f929c5af
--- /dev/null
+++ b/net/pppoa/files/patch-doc-install
@@ -0,0 +1,27 @@
+--- doc-bsd/Makefile.in.orig Wed Sep 29 21:56:31 2004
++++ doc-bsd/Makefile.in Mon Jan 24 20:10:17 2005
+@@ -51,6 +51,7 @@
+ make_bindir=${rootdir}/bin
+ include= -I. -I${includedir} -I${oldincludedir}
+ INSTALL=@INSTALL@
++INSTALL_MAN=@INSTALL_MAN@
+ installuser=@installuser@
+
+ man1dir=${mandir}/man1
+@@ -106,13 +107,10 @@
+
+ install-man:
+ @test -d "$(man1dir)" || $(INSTALL) -c -d "$(man1dir)"
+- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/speedtouch-setup.1 "$(man1dir)"
+- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/speedtouch-start.1 "$(man1dir)"
+- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/speedtouch-stop.1 "$(man1dir)"
+ @test -d "$(man8dir)" || $(INSTALL) -c -d "$(man8dir)"
+- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/modem_run.8 "$(man8dir)"
+- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/pppoa2.8 "$(man8dir)"
+- $(INSTALL) -m 0444 -o $(installuser) ../doc-linux/man/pppoa3.8 "$(man8dir)"
++ $(INSTALL_MAN) ../doc-linux/man/modem_run.8 "$(man8dir)"
++ $(INSTALL_MAN) ../doc-linux/man/pppoa2.8 "$(man8dir)"
++ $(INSTALL_MAN) ../doc-linux/man/pppoa3.8 "$(man8dir)"
+
+ uninstall :
+ rm -rf "$(docdir)"
diff --git a/net/pppoa/files/patch-src-install b/net/pppoa/files/patch-src-install
new file mode 100644
index 000000000000..0b2c09ddead2
--- /dev/null
+++ b/net/pppoa/files/patch-src-install
@@ -0,0 +1,14 @@
+--- src/Makefile.in.orig Wed Sep 29 21:56:31 2004
++++ src/Makefile.in Mon Jan 24 17:55:49 2005
+@@ -184,11 +184,6 @@
+ rm -f Makefile
+
+ install:
+- $(INSTALL) -d "$(bindir)"
+- $(INSTALL) -m 0755 speedtouch-setup "$(bindir)"
+- $(INSTALL) -m 0755 speedtouch-start "$(bindir)"
+- $(INSTALL) -m 0755 speedtouch-stop "$(bindir)"
+- $(INSTALL) -d "$(sysconfdir)/speedtouch"
+
+ uninstall:
+ $(RM) "$(bindir)/speedtouch-setup"
diff --git a/net/pppoa/pkg-plist b/net/pppoa/pkg-plist
index 8a501c773ea2..398bcb962548 100644
--- a/net/pppoa/pkg-plist
+++ b/net/pppoa/pkg-plist
@@ -1,6 +1,3 @@
-bin/speedtouch-setup
-bin/speedtouch-start
-bin/speedtouch-stop
sbin/modem_run
sbin/pppoa2
sbin/pppoa3