aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2007-01-30 00:55:42 +0800
committeroliver <oliver@FreeBSD.org>2007-01-30 00:55:42 +0800
commit146695d33925c75c33ef4f0527b7f09fb9224d27 (patch)
tree2e5acdb78b1c65fe0a3a3bea6684fd719f848559
parent41e25f7f0c9ba4cc0178fd7a087610ca76bbfb43 (diff)
downloadfreebsd-ports-gnome-146695d33925c75c33ef4f0527b7f09fb9224d27.tar.gz
freebsd-ports-gnome-146695d33925c75c33ef4f0527b7f09fb9224d27.tar.zst
freebsd-ports-gnome-146695d33925c75c33ef4f0527b7f09fb9224d27.zip
add HAL and NOTIFY to the OPTIONS and enable them by default
bump PORTREVISION
-rw-r--r--x11/libexo/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index cd242f0c6e4f..716193ea2b3c 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libexo
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= x11 xfce
DISTNAME= exo-${PORTVERSION}
MASTER_SITES= ${MASTER_SITES_XFCE}
@@ -33,7 +34,9 @@ USE_LDCONFIG= yes
USE_XFCE= configenv libutil mcsmanager
USE_XLIB= yes
-OPTIONS= PYTHON "Enable Python support" off \
+OPTIONS= HAL "Enable HAL support" on \
+ NOTIFY "Enable notification support" on \
+ PYTHON "Enable Python support" off \
GTKDOC "Build with documentation" off \
MCS "Build with xfce4-mcs-manager support" on
@@ -51,6 +54,20 @@ CONFIGURE_ARGS+=--disable-gtk-doc
PLIST_SUB+= GTK_DOC="@comment "
.endif
+.if defined(WITH_HAL)
+CONFIGURE_ARGS+=--enable-hal
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+.else
+CONFIGURE_ARGS+=--disable-hal
+.endif
+
+.if defined(WITH_NOTIFY)
+CONFIGURE_ARGS+=--enable-notifications
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+.else
+CONFIGURE_ARGS+=--disable-notifications
+.endif
+
.if defined(WITH_PYTHON)
CONFIGURE_ARGS+=--enable-python
USE_PYTHON= yes