aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-01-17 21:57:21 +0800
committerosa <osa@FreeBSD.org>2010-01-17 21:57:21 +0800
commit1471dafdeba253ba0b4c83f602c8a914ead8c0a1 (patch)
tree1c2e02cd5f41398e33fb39922a2a40643c3cb7df
parent26cc8860f82e9158da2220e309c999057404cf56 (diff)
downloadfreebsd-ports-gnome-1471dafdeba253ba0b4c83f602c8a914ead8c0a1.tar.gz
freebsd-ports-gnome-1471dafdeba253ba0b4c83f602c8a914ead8c0a1.tar.zst
freebsd-ports-gnome-1471dafdeba253ba0b4c83f602c8a914ead8c0a1.zip
Update from 1.02 to 1.2.0.
Adopt patch for redis.conf. Previously and by default redis was compiled with debugging information, that didn't respect CFLAGS. So, now its possible to compile with debugging information by use WITH_DEBUG knob. Take maintainership. Approved by: maintainer (skv@)
-rw-r--r--databases/redis-devel/Makefile15
-rw-r--r--databases/redis-devel/distinfo6
-rw-r--r--databases/redis-devel/files/patch-redis.conf24
-rw-r--r--databases/redis/Makefile15
-rw-r--r--databases/redis/distinfo6
-rw-r--r--databases/redis/files/patch-redis.conf24
-rw-r--r--databases/redis1/Makefile15
-rw-r--r--databases/redis1/distinfo6
-rw-r--r--databases/redis1/files/patch-redis.conf24
-rw-r--r--databases/redis2/Makefile15
-rw-r--r--databases/redis2/distinfo6
-rw-r--r--databases/redis2/files/patch-redis.conf24
12 files changed, 104 insertions, 76 deletions
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index 3d0f18a82900..849fc7075d2c 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -6,19 +6,18 @@
#
PORTNAME= redis
-PORTVERSION= 1.02
+PORTVERSION= 1.2.0
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= osa@FreeBSD.org
COMMENT= A persistent key-value database with built-in net interface
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
USE_RC_SUBR= redis.sh
BIN_FILES= redis-server redis-benchmark redis-cli
@@ -45,6 +44,14 @@ SUB_LIST+= PORTNAME="${PORTNAME}" \
REDIS_DBDIR="${REDIS_DBDIR}" \
REDIS_RUNDIR="${REDIS_RUNDIR}"
+PATTERN= '10d;13s|$$$$(ARCH) ||'
+.if !defined(WITH_DEBUG)
+PATTERN:= ${PATTERN:S/'$/;14s|^|\#|'/}
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} ${PATTERN} ${WRKSRC}/Makefile
+
post-build:
${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/redis.conf > ${WRKDIR}/redis.conf
diff --git a/databases/redis-devel/distinfo b/databases/redis-devel/distinfo
index 93fede6b6b18..b552cb5ddc81 100644
--- a/databases/redis-devel/distinfo
+++ b/databases/redis-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (redis-1.02.tar.gz) = 5396e2d8b67f451ab4702ce7655533ae
-SHA256 (redis-1.02.tar.gz) = aa1fe425568e19bcf89db9a48df68a42732134c29978e27c6e9c05008a73321e
-SIZE (redis-1.02.tar.gz) = 202973
+MD5 (redis-1.2.0.tar.gz) = e33cb95cfa5c4f7086eea57e1e490d28
+SHA256 (redis-1.2.0.tar.gz) = 88fdc5433de3a0c77895b6b5f86d69b7a8a8575d042af68ba1cb24c996faa9bf
+SIZE (redis-1.2.0.tar.gz) = 202685
diff --git a/databases/redis-devel/files/patch-redis.conf b/databases/redis-devel/files/patch-redis.conf
index f68bd795ad4a..4aab6fedaf65 100644
--- a/databases/redis-devel/files/patch-redis.conf
+++ b/databases/redis-devel/files/patch-redis.conf
@@ -1,5 +1,5 @@
---- redis.conf
-+++ redis.conf
+--- redis.conf.orig 2009-12-27 11:54:09.000000000 +0300
++++ redis.conf 2009-12-27 11:56:16.000000000 +0300
@@ -2,11 +2,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
@@ -14,16 +14,7 @@
# Accept connections on the specified port, default is 6379
port 6379
-@@ -39,7 +39,7 @@
-
- # For default save/load DB in/from the working directory
- # Note that you must specify a directory not a file name.
--dir ./
-+dir %%REDIS_DBDIR%%/
-
- # Set server verbosity to 'debug'
- # it can be one of:
-@@ -51,7 +51,7 @@
+@@ -29,7 +29,7 @@
# Specify the log file name. Also 'stdout' can be used to force
# the demon to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
@@ -32,3 +23,12 @@
# Set the number of databases. The default database is DB 0, you can select
# a different one on a per-connection basis using SELECT <dbid> where
+@@ -64,7 +64,7 @@
+
+ # For default save/load DB in/from the working directory
+ # Note that you must specify a directory not a file name.
+-dir ./
++dir %%REDIS_DBDIR%%/
+
+ ################################# REPLICATION #################################
+
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 3d0f18a82900..849fc7075d2c 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -6,19 +6,18 @@
#
PORTNAME= redis
-PORTVERSION= 1.02
+PORTVERSION= 1.2.0
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= osa@FreeBSD.org
COMMENT= A persistent key-value database with built-in net interface
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
USE_RC_SUBR= redis.sh
BIN_FILES= redis-server redis-benchmark redis-cli
@@ -45,6 +44,14 @@ SUB_LIST+= PORTNAME="${PORTNAME}" \
REDIS_DBDIR="${REDIS_DBDIR}" \
REDIS_RUNDIR="${REDIS_RUNDIR}"
+PATTERN= '10d;13s|$$$$(ARCH) ||'
+.if !defined(WITH_DEBUG)
+PATTERN:= ${PATTERN:S/'$/;14s|^|\#|'/}
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} ${PATTERN} ${WRKSRC}/Makefile
+
post-build:
${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/redis.conf > ${WRKDIR}/redis.conf
diff --git a/databases/redis/distinfo b/databases/redis/distinfo
index 93fede6b6b18..b552cb5ddc81 100644
--- a/databases/redis/distinfo
+++ b/databases/redis/distinfo
@@ -1,3 +1,3 @@
-MD5 (redis-1.02.tar.gz) = 5396e2d8b67f451ab4702ce7655533ae
-SHA256 (redis-1.02.tar.gz) = aa1fe425568e19bcf89db9a48df68a42732134c29978e27c6e9c05008a73321e
-SIZE (redis-1.02.tar.gz) = 202973
+MD5 (redis-1.2.0.tar.gz) = e33cb95cfa5c4f7086eea57e1e490d28
+SHA256 (redis-1.2.0.tar.gz) = 88fdc5433de3a0c77895b6b5f86d69b7a8a8575d042af68ba1cb24c996faa9bf
+SIZE (redis-1.2.0.tar.gz) = 202685
diff --git a/databases/redis/files/patch-redis.conf b/databases/redis/files/patch-redis.conf
index f68bd795ad4a..4aab6fedaf65 100644
--- a/databases/redis/files/patch-redis.conf
+++ b/databases/redis/files/patch-redis.conf
@@ -1,5 +1,5 @@
---- redis.conf
-+++ redis.conf
+--- redis.conf.orig 2009-12-27 11:54:09.000000000 +0300
++++ redis.conf 2009-12-27 11:56:16.000000000 +0300
@@ -2,11 +2,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
@@ -14,16 +14,7 @@
# Accept connections on the specified port, default is 6379
port 6379
-@@ -39,7 +39,7 @@
-
- # For default save/load DB in/from the working directory
- # Note that you must specify a directory not a file name.
--dir ./
-+dir %%REDIS_DBDIR%%/
-
- # Set server verbosity to 'debug'
- # it can be one of:
-@@ -51,7 +51,7 @@
+@@ -29,7 +29,7 @@
# Specify the log file name. Also 'stdout' can be used to force
# the demon to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
@@ -32,3 +23,12 @@
# Set the number of databases. The default database is DB 0, you can select
# a different one on a per-connection basis using SELECT <dbid> where
+@@ -64,7 +64,7 @@
+
+ # For default save/load DB in/from the working directory
+ # Note that you must specify a directory not a file name.
+-dir ./
++dir %%REDIS_DBDIR%%/
+
+ ################################# REPLICATION #################################
+
diff --git a/databases/redis1/Makefile b/databases/redis1/Makefile
index 3d0f18a82900..849fc7075d2c 100644
--- a/databases/redis1/Makefile
+++ b/databases/redis1/Makefile
@@ -6,19 +6,18 @@
#
PORTNAME= redis
-PORTVERSION= 1.02
+PORTVERSION= 1.2.0
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= osa@FreeBSD.org
COMMENT= A persistent key-value database with built-in net interface
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
USE_RC_SUBR= redis.sh
BIN_FILES= redis-server redis-benchmark redis-cli
@@ -45,6 +44,14 @@ SUB_LIST+= PORTNAME="${PORTNAME}" \
REDIS_DBDIR="${REDIS_DBDIR}" \
REDIS_RUNDIR="${REDIS_RUNDIR}"
+PATTERN= '10d;13s|$$$$(ARCH) ||'
+.if !defined(WITH_DEBUG)
+PATTERN:= ${PATTERN:S/'$/;14s|^|\#|'/}
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} ${PATTERN} ${WRKSRC}/Makefile
+
post-build:
${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/redis.conf > ${WRKDIR}/redis.conf
diff --git a/databases/redis1/distinfo b/databases/redis1/distinfo
index 93fede6b6b18..b552cb5ddc81 100644
--- a/databases/redis1/distinfo
+++ b/databases/redis1/distinfo
@@ -1,3 +1,3 @@
-MD5 (redis-1.02.tar.gz) = 5396e2d8b67f451ab4702ce7655533ae
-SHA256 (redis-1.02.tar.gz) = aa1fe425568e19bcf89db9a48df68a42732134c29978e27c6e9c05008a73321e
-SIZE (redis-1.02.tar.gz) = 202973
+MD5 (redis-1.2.0.tar.gz) = e33cb95cfa5c4f7086eea57e1e490d28
+SHA256 (redis-1.2.0.tar.gz) = 88fdc5433de3a0c77895b6b5f86d69b7a8a8575d042af68ba1cb24c996faa9bf
+SIZE (redis-1.2.0.tar.gz) = 202685
diff --git a/databases/redis1/files/patch-redis.conf b/databases/redis1/files/patch-redis.conf
index f68bd795ad4a..4aab6fedaf65 100644
--- a/databases/redis1/files/patch-redis.conf
+++ b/databases/redis1/files/patch-redis.conf
@@ -1,5 +1,5 @@
---- redis.conf
-+++ redis.conf
+--- redis.conf.orig 2009-12-27 11:54:09.000000000 +0300
++++ redis.conf 2009-12-27 11:56:16.000000000 +0300
@@ -2,11 +2,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
@@ -14,16 +14,7 @@
# Accept connections on the specified port, default is 6379
port 6379
-@@ -39,7 +39,7 @@
-
- # For default save/load DB in/from the working directory
- # Note that you must specify a directory not a file name.
--dir ./
-+dir %%REDIS_DBDIR%%/
-
- # Set server verbosity to 'debug'
- # it can be one of:
-@@ -51,7 +51,7 @@
+@@ -29,7 +29,7 @@
# Specify the log file name. Also 'stdout' can be used to force
# the demon to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
@@ -32,3 +23,12 @@
# Set the number of databases. The default database is DB 0, you can select
# a different one on a per-connection basis using SELECT <dbid> where
+@@ -64,7 +64,7 @@
+
+ # For default save/load DB in/from the working directory
+ # Note that you must specify a directory not a file name.
+-dir ./
++dir %%REDIS_DBDIR%%/
+
+ ################################# REPLICATION #################################
+
diff --git a/databases/redis2/Makefile b/databases/redis2/Makefile
index 3d0f18a82900..849fc7075d2c 100644
--- a/databases/redis2/Makefile
+++ b/databases/redis2/Makefile
@@ -6,19 +6,18 @@
#
PORTNAME= redis
-PORTVERSION= 1.02
+PORTVERSION= 1.2.0
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= osa@FreeBSD.org
COMMENT= A persistent key-value database with built-in net interface
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
USE_RC_SUBR= redis.sh
BIN_FILES= redis-server redis-benchmark redis-cli
@@ -45,6 +44,14 @@ SUB_LIST+= PORTNAME="${PORTNAME}" \
REDIS_DBDIR="${REDIS_DBDIR}" \
REDIS_RUNDIR="${REDIS_RUNDIR}"
+PATTERN= '10d;13s|$$$$(ARCH) ||'
+.if !defined(WITH_DEBUG)
+PATTERN:= ${PATTERN:S/'$/;14s|^|\#|'/}
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} ${PATTERN} ${WRKSRC}/Makefile
+
post-build:
${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/redis.conf > ${WRKDIR}/redis.conf
diff --git a/databases/redis2/distinfo b/databases/redis2/distinfo
index 93fede6b6b18..b552cb5ddc81 100644
--- a/databases/redis2/distinfo
+++ b/databases/redis2/distinfo
@@ -1,3 +1,3 @@
-MD5 (redis-1.02.tar.gz) = 5396e2d8b67f451ab4702ce7655533ae
-SHA256 (redis-1.02.tar.gz) = aa1fe425568e19bcf89db9a48df68a42732134c29978e27c6e9c05008a73321e
-SIZE (redis-1.02.tar.gz) = 202973
+MD5 (redis-1.2.0.tar.gz) = e33cb95cfa5c4f7086eea57e1e490d28
+SHA256 (redis-1.2.0.tar.gz) = 88fdc5433de3a0c77895b6b5f86d69b7a8a8575d042af68ba1cb24c996faa9bf
+SIZE (redis-1.2.0.tar.gz) = 202685
diff --git a/databases/redis2/files/patch-redis.conf b/databases/redis2/files/patch-redis.conf
index f68bd795ad4a..4aab6fedaf65 100644
--- a/databases/redis2/files/patch-redis.conf
+++ b/databases/redis2/files/patch-redis.conf
@@ -1,5 +1,5 @@
---- redis.conf
-+++ redis.conf
+--- redis.conf.orig 2009-12-27 11:54:09.000000000 +0300
++++ redis.conf 2009-12-27 11:56:16.000000000 +0300
@@ -2,11 +2,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
@@ -14,16 +14,7 @@
# Accept connections on the specified port, default is 6379
port 6379
-@@ -39,7 +39,7 @@
-
- # For default save/load DB in/from the working directory
- # Note that you must specify a directory not a file name.
--dir ./
-+dir %%REDIS_DBDIR%%/
-
- # Set server verbosity to 'debug'
- # it can be one of:
-@@ -51,7 +51,7 @@
+@@ -29,7 +29,7 @@
# Specify the log file name. Also 'stdout' can be used to force
# the demon to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
@@ -32,3 +23,12 @@
# Set the number of databases. The default database is DB 0, you can select
# a different one on a per-connection basis using SELECT <dbid> where
+@@ -64,7 +64,7 @@
+
+ # For default save/load DB in/from the working directory
+ # Note that you must specify a directory not a file name.
+-dir ./
++dir %%REDIS_DBDIR%%/
+
+ ################################# REPLICATION #################################
+