aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-10-21 00:24:04 +0800
committerdanfe <danfe@FreeBSD.org>2013-10-21 00:24:04 +0800
commit149e8c755d05e3e17a483ed64130ed142cff5088 (patch)
tree361d971a6d23534f5c945f780ff6620b64c9c69d
parent19e94ba1a9b6e8b82fd4c909fc1a76a9ceaea619 (diff)
downloadfreebsd-ports-gnome-149e8c755d05e3e17a483ed64130ed142cff5088.tar.gz
freebsd-ports-gnome-149e8c755d05e3e17a483ed64130ed142cff5088.tar.zst
freebsd-ports-gnome-149e8c755d05e3e17a483ed64130ed142cff5088.zip
Stagify; simplify one regex; do not hardcode operating system name.
PR: ports/182535 Submitted by: amdmi3
-rw-r--r--games/qstat/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/games/qstat/Makefile b/games/qstat/Makefile
index 0b0c90e20a16..4e008e0e152b 100644
--- a/games/qstat/Makefile
+++ b/games/qstat/Makefile
@@ -15,26 +15,18 @@ CONFLICTS_INSTALL= torque-[0-9]*
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-extract:
@${MV} ${WRKSRC}/qstat.cfg ${WRKSRC}/qstat.cfg.default
post-patch:
- @${REINPLACE_CMD} -e 's|\(qstat\.cfg\)|\1\.default|' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|OpenBSD|FreeBSD|' ${WRKSRC}/qstat.c
+ @${REINPLACE_CMD} -e 's|qstat\.cfg|&.default|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|OpenBSD|${OPSYS}|' ${WRKSRC}/qstat.c
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}/info ${DOCSDIR}/template
- ${INSTALL_DATA} ${WRKSRC}/qstatdoc.html ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/info ${STAGEDIR}${DOCSDIR}/template
+ ${INSTALL_DATA} ${WRKSRC}/qstatdoc.html ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/template/*.html ${WRKSRC}/template/*.txt \
- ${DOCSDIR}/template
- ${INSTALL_DATA} ${WRKSRC}/info/*.txt ${DOCSDIR}/info
-.endif
- @[ -f ${PREFIX}/etc/qstat.cfg ] || \
- ${CP} ${PREFIX}/etc/qstat.cfg.default ${PREFIX}/etc/qstat.cfg
+ ${STAGEDIR}${DOCSDIR}/template
+ ${INSTALL_DATA} ${WRKSRC}/info/*.txt ${STAGEDIR}${DOCSDIR}/info
.include <bsd.port.mk>