aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-10-06 10:54:50 +0800
committerlioux <lioux@FreeBSD.org>2002-10-06 10:54:50 +0800
commit16b52b47f7e29aa5f904f8f7f069516c32bac7fc (patch)
treeb0f28e9c862ace3710061262a42b5a7d68a8e6f0
parent10f32b4737e75b85c3141cd3ffec8166853b7083 (diff)
downloadfreebsd-ports-gnome-16b52b47f7e29aa5f904f8f7f069516c32bac7fc.tar.gz
freebsd-ports-gnome-16b52b47f7e29aa5f904f8f7f069516c32bac7fc.tar.zst
freebsd-ports-gnome-16b52b47f7e29aa5f904f8f7f069516c32bac7fc.zip
New port xmms-speex version 0.6.0: XMMS input plugin to play speex
files Submitted by: David Yeske <dyeske@yahoo.com>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xmms-speex/Makefile39
-rw-r--r--audio/xmms-speex/distinfo1
-rw-r--r--audio/xmms-speex/files/patch-libspeex.c20
-rw-r--r--audio/xmms-speex/pkg-comment1
-rw-r--r--audio/xmms-speex/pkg-descr6
-rw-r--r--audio/xmms-speex/pkg-plist1
7 files changed, 69 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1bd1193e39c1..125ccf338095 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -295,6 +295,7 @@
SUBDIR += xmms-sid
SUBDIR += xmms-sndfile
SUBDIR += xmms-sndstretch
+ SUBDIR += xmms-speex
SUBDIR += xmms-tfmx
SUBDIR += xmms-volnorm
SUBDIR += xmp
diff --git a/audio/xmms-speex/Makefile b/audio/xmms-speex/Makefile
new file mode 100644
index 000000000000..7e808dc788ff
--- /dev/null
+++ b/audio/xmms-speex/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: xmms-speex
+# Date created: 3 Oct 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-speex
+PORTVERSION= 0.6.0
+CATEGORIES= audio
+MASTER_SITES= http://jzb.rapanden.dk/speex/
+DISTNAME= speex-xmms-${PORTVERSION}
+
+MAINTAINER= dyeske@yahoo.com
+
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+LIB_DEPENDS= speex.0:${PORTSDIR}/audio/speex
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+WRKSRC= ${WRKDIR}/speex-xmms
+
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+pre-build:
+ @${REINPLACE_CMD} -e 's|^main|all|; \
+ s|-lgtk|${CFLAGS} `${GTK_CONFIG} --cflags` `${GTK_CONFIG} --libs` |; \
+ s|-I/usr/include/xmms||; \
+ s|^install: libspeex.o|install:|; \
+ s|-I/usr/lib/glib/include||; \
+ s|-I/usr/include/glib-1.2||; \
+ s|-I/usr/include/gtk-1.2||; \
+ s|/usr/lib/xmms/Input|${X11BASE}/lib/xmms/Input|' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-speex/distinfo b/audio/xmms-speex/distinfo
new file mode 100644
index 000000000000..6fa78ad5d89f
--- /dev/null
+++ b/audio/xmms-speex/distinfo
@@ -0,0 +1 @@
+MD5 (speex-xmms-0.6.0.tar.gz) = b4014356ef929706444ff98639550460
diff --git a/audio/xmms-speex/files/patch-libspeex.c b/audio/xmms-speex/files/patch-libspeex.c
new file mode 100644
index 000000000000..6bfc4c4e7ccf
--- /dev/null
+++ b/audio/xmms-speex/files/patch-libspeex.c
@@ -0,0 +1,20 @@
+--- libspeex.c.orig Sat Sep 21 13:18:53 2002
++++ libspeex.c Sat Sep 21 13:23:14 2002
+@@ -385,7 +385,7 @@
+ #endif
+
+ speex_bits_rewind(&sbits);
+- speex_decode(spx_decoder, &sbits, outbuff, 1);
++ speex_decode(spx_decoder, &sbits, outbuff);
+
+ // Converting and clipping check
+ for (i = 0; i < speex_fs->framesize; i++) {
+@@ -455,7 +455,7 @@
+ // For multiple frames within packets
+ for (j=0; j < speex_fs->nframes; j++)
+ {
+- speex_decode(spx_decoder, &sbits, outbuff, 0);
++ speex_decode(spx_decoder, &sbits, outbuff);
+
+ // Converting and clipping check
+ for (i = 0; i < speex_fs->framesize; i++) {
diff --git a/audio/xmms-speex/pkg-comment b/audio/xmms-speex/pkg-comment
new file mode 100644
index 000000000000..93b0014bb7d0
--- /dev/null
+++ b/audio/xmms-speex/pkg-comment
@@ -0,0 +1 @@
+XMMS input plugin to play speex files
diff --git a/audio/xmms-speex/pkg-descr b/audio/xmms-speex/pkg-descr
new file mode 100644
index 000000000000..8280a3226e70
--- /dev/null
+++ b/audio/xmms-speex/pkg-descr
@@ -0,0 +1,6 @@
+A plugin to make xmms play files compressed with the Speex codec
+
+WWW: http://jzb.rapanden.dk/speex/
+
+- David
+dyeske@yahoo.com
diff --git a/audio/xmms-speex/pkg-plist b/audio/xmms-speex/pkg-plist
new file mode 100644
index 000000000000..af8cf8f4cf44
--- /dev/null
+++ b/audio/xmms-speex/pkg-plist
@@ -0,0 +1 @@
+lib/xmms/Input/libspeex.so