aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2015-04-28 03:31:23 +0800
committerjohans <johans@FreeBSD.org>2015-04-28 03:31:23 +0800
commit17c70a934aa438e0ae5121b9101cca2709580f2c (patch)
treee64587234f49af43376e5f91ebe464ecbb3f3deb
parent70b84ad6281bf24c6b560c3a2ea7d60c4ca4fe01 (diff)
downloadfreebsd-ports-gnome-17c70a934aa438e0ae5121b9101cca2709580f2c.tar.gz
freebsd-ports-gnome-17c70a934aa438e0ae5121b9101cca2709580f2c.tar.zst
freebsd-ports-gnome-17c70a934aa438e0ae5121b9101cca2709580f2c.zip
Avoid perl 5.20 specific construct
Fixes caff with perl 5.18 Submitted by: Mike Burns
-rw-r--r--security/signing-party/Makefile1
-rw-r--r--security/signing-party/files/patch-caff_caff15
2 files changed, 16 insertions, 0 deletions
diff --git a/security/signing-party/Makefile b/security/signing-party/Makefile
index bbb485499873..4eeabccba4b4 100644
--- a/security/signing-party/Makefile
+++ b/security/signing-party/Makefile
@@ -3,6 +3,7 @@
PORTNAME= signing-party
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.stack.nl/pub/users/johans/signing-party/ \
${MASTER_SITE_DEBIAN}
diff --git a/security/signing-party/files/patch-caff_caff b/security/signing-party/files/patch-caff_caff
new file mode 100644
index 000000000000..d27185a16628
--- /dev/null
+++ b/security/signing-party/files/patch-caff_caff
@@ -0,0 +1,15 @@
+Avoid construct that only works in perl 5.20
+
+--- caff/caff.orig 2015-04-27 21:19:22.000000000 +0200
++++ caff/caff 2015-04-27 21:19:28.000000000 +0200
+@@ -714,7 +714,9 @@ sub readwrite_gpg($%) {
+ # ignore direct and dup handles
+ my @infhs = grep {defined $opts{$_} and !$handles->options($_)->{direct} and $handles->{$_} !~ /^[<>]&/} qw/stdin passphrase command/;
+ my @outfhs = grep {defined $handles->{$_} and !$handles->options($_)->{direct} and $handles->{$_} !~ /^[<>]&/} qw/stdout stderr status logger/;
+- my %fh = reverse %$handles{@infhs, @outfhs};
++ my %fh;
++ $fh{$_} = $handles->{$_} foreach (@infhs, @outfhs);
++ %fh = reverse %fh;
+
+ my %offset = map {$_ => 0} @infhs;
+ my %output = map {$_ => ''} @outfhs;