aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-06-24 21:54:22 +0800
committerwg <wg@FreeBSD.org>2013-06-24 21:54:22 +0800
commit18178c96d1ebb739cbcd43501795f38f1282bd7b (patch)
tree615aa88ccb0523a6268c976c192fee5d2ffcb310
parent53dce76e26fd32e1615cb8bed6ab3bc076aa6fa4 (diff)
downloadfreebsd-ports-gnome-18178c96d1ebb739cbcd43501795f38f1282bd7b.tar.gz
freebsd-ports-gnome-18178c96d1ebb739cbcd43501795f38f1282bd7b.tar.zst
freebsd-ports-gnome-18178c96d1ebb739cbcd43501795f38f1282bd7b.zip
games/thegrind: fix build depends
- Fix BUILD_DEPENDS: needs a static library [1] - Remove leading article in COMMENT [2] - Add maintainer alias in Makefile [2] - Add DOCS option and unmute docs mkdir [2] PR: ports/179882 Submitted by: John Marino <draco@marino.st> [1], maintainer [2]
-rw-r--r--games/thegrind/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/games/thegrind/Makefile b/games/thegrind/Makefile
index 830b40ddd9e1..f8a98de4bd70 100644
--- a/games/thegrind/Makefile
+++ b/games/thegrind/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= thegrind
@@ -8,38 +8,41 @@ CATEGORIES= games
MASTER_SITES= SF/radius-engine/ld21/
MAINTAINER= nemysis@gmx.ch
-COMMENT= A simple game about escaping from work
+COMMENT= Simple game about escaping from work
LICENSE= GPLv2
-LIB_DEPENDS= radius:${PORTSDIR}/graphics/radius-engine \
- lua-5.1:${PORTSDIR}/lang/lua \
+BUILD_DEPENDS= ${LOCALBASE}/lib/libradius-engine.a:${PORTSDIR}/graphics/radius-engine
+LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua \
png15:${PORTSDIR}/graphics/png \
physfs.1:${PORTSDIR}/devel/physfs
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
USES= pkgconfig
-GNU_CONFIGURE= yes
-ALL_TARGET= ${PORTNAME}
USE_SDL= sdl sound
USE_GL= glu
+GNU_CONFIGURE= yes
+ALL_TARGET= ${PORTNAME}
+
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/${PORTNAME} \
share/applications/${PORTNAME}.desktop \
- share/pixmaps/${PORTNAME}.png
+ share/pixmaps/${PORTNAME}.png \
+ %%DATADIR%%/${PORTNAME}.zip
+PLIST_DIRS= %%DATADIR%%
PLIST_DIRSTRY= share/applications
-PORTDATA= *
PORTDOCS= ChangeLog
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>