aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2010-05-13 03:04:03 +0800
committernox <nox@FreeBSD.org>2010-05-13 03:04:03 +0800
commit186b0a01e20bfc1087a2c975e5fa5554aab583c3 (patch)
treec2ecea98c933e5e90ff6554bcef19a3bb38cd459
parentfcf8af5e85836127d196eb410f04b7baf855d85b (diff)
downloadfreebsd-ports-gnome-186b0a01e20bfc1087a2c975e5fa5554aab583c3.tar.gz
freebsd-ports-gnome-186b0a01e20bfc1087a2c975e5fa5554aab583c3.tar.zst
freebsd-ports-gnome-186b0a01e20bfc1087a2c975e5fa5554aab583c3.zip
Fix build for nonstandard PREFIX / LOCALBASE.
PR: ports/146506 Submitted by: kmoore
-rw-r--r--astro/google-earth/Makefile2
-rw-r--r--astro/google-earth/files/patch-stacksize4
2 files changed, 3 insertions, 3 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 66a395850ce0..62c8355201ed 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -53,7 +53,7 @@ do-extract:
@cd ${WRKSRC} && ${TAR} xf googleearth-data.tar && ${RM} -f googleearth-data.tar
@cd ${WRKSRC} && ${TAR} xf googleearth-linux-x86.tar && ${RM} -f googleearth-linux-x86.tar
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -i "" -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f \$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e 's/^TMPPATH.*/exit 0/' ${WRKSRC}/postinstall.sh
diff --git a/astro/google-earth/files/patch-stacksize b/astro/google-earth/files/patch-stacksize
index 1927d545a67e..f30765e88d9c 100644
--- a/astro/google-earth/files/patch-stacksize
+++ b/astro/google-earth/files/patch-stacksize
@@ -1,10 +1,10 @@
Index: bin/googleearth
-@@ -34,6 +34,8 @@
+@@ -34,6 +34,8 @@ FindPath()
dirname $fullpath
}
+ulimit -s 32768 2>/dev/null
+
- GOOGLEEARTH_DATA_PATH=/usr/local/share/google-earth
+ # Set the home if not already set.
if [ "${GOOGLEEARTH_DATA_PATH}" = "" ]; then
GOOGLEEARTH_DATA_PATH="`FindPath $0`"