aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-10-18 02:15:53 +0800
committerlioux <lioux@FreeBSD.org>2001-10-18 02:15:53 +0800
commit190e2efd41ff27be1bad490117f547f36d16bd4c (patch)
treed25fd7f1bdea45e0d162b220270235a1782aba62
parent9f21364ee03bedb505aef5ce1cba034b125b054a (diff)
downloadfreebsd-ports-gnome-190e2efd41ff27be1bad490117f547f36d16bd4c.tar.gz
freebsd-ports-gnome-190e2efd41ff27be1bad490117f547f36d16bd4c.tar.zst
freebsd-ports-gnome-190e2efd41ff27be1bad490117f547f36d16bd4c.zip
fix some maps which are truncated in the official distribution
Submitted by: MAINTAINER (with few changes)
-rw-r--r--games/utserver/Makefile21
1 files changed, 19 insertions, 2 deletions
diff --git a/games/utserver/Makefile b/games/utserver/Makefile
index 0488a2e24201..e3d369ffc3a6 100644
--- a/games/utserver/Makefile
+++ b/games/utserver/Makefile
@@ -7,10 +7,17 @@
PORTNAME= utserver
PORTVERSION= 436
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= ftp://utservers:idspispopd@ftp.lokigames.com/ \
- http://arcadia.inf.udec.cl/ftp/pub/linux/ut-server/
-DISTNAME= ut-server-${PORTVERSION}
+ http://arcadia.inf.udec.cl/ftp/pub/linux/ut-server/ \
+ http://ucc.sobservers.com/ \
+ http://game.dkm.cz/downloads/files/Unreal%20Tournament/ucc/
+DISTFILES= ut-server-${PORTVERSION}${EXTRACT_SUFX} \
+ DM-Curse%5D%5B.unr.uz \
+ DM-Deck16%5D%5B.unr.uz \
+ DM-Morbias%5D%5B.unr.uz
+EXTRACT_ONLY= ut-server-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= matuska@wu-wien.ac.at
@@ -31,6 +38,16 @@ SORT?= /usr/bin/sort
# files which should be installed with executable perms
EXECUTABLES= ucc ucc-bin
+post-extract:
+.for file in ${DISTFILES:S/${EXTRACT_ONLY}//}
+ @${SETENV} HOME=${WRKDIR} ${WRKSRC}/ucc decompress \
+ ${DISTDIR}/${file} >/dev/null
+.endfor
+.for file in ${DISTFILES:S/${EXTRACT_ONLY}//}
+ @${CP} -f "${WRKDIR}/.loki/ut/System/${file:R:S/%5D/]/:S/%5B/[/}" \
+ ${WRKSRC}/Maps
+.endfor
+
pre-patch:
# remove trailing ^M
@find -E ${WRKSRC} -type f \