aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2013-08-10 23:08:22 +0800
committervg <vg@FreeBSD.org>2013-08-10 23:08:22 +0800
commit1ac6a624f3d40473d908340b3deeacbb7e99b693 (patch)
tree541e54aaaba902f85b590aaa6901e6f4fc4057cd
parentecbe9c184dcf77ae44b9ee65ee8c2066aa0f2203 (diff)
downloadfreebsd-ports-gnome-1ac6a624f3d40473d908340b3deeacbb7e99b693.tar.gz
freebsd-ports-gnome-1ac6a624f3d40473d908340b3deeacbb7e99b693.tar.zst
freebsd-ports-gnome-1ac6a624f3d40473d908340b3deeacbb7e99b693.zip
- Added conflict with Qt3
- Fixed build with new glibc PR: ports/175429 Submitted by: Heino Tiedemann <rotkap@gmx.de> Approved by: eadler (mentor)
-rw-r--r--audio/clementine-player/Makefile1
-rw-r--r--audio/clementine-player/files/patch-src-main.cpp12
2 files changed, 13 insertions, 0 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index d7d039a51acc..46294b872f07 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -33,6 +33,7 @@ USE_GCC= 4.2+
INSTALLS_ICONS= yes
USE_GSTREAMER= gio ogg mp3 flac soup vorbis
MAKE_JOBS_UNSAFE= yes
+CONFLICTS_BUILD= qt-3.*
CMAKE_ARGS+= -DCMAKE_LIBRARY_PATH:PATH="${LOCALBASE}/lib:${PREFIX}/lib"
diff --git a/audio/clementine-player/files/patch-src-main.cpp b/audio/clementine-player/files/patch-src-main.cpp
new file mode 100644
index 000000000000..54490be8a55a
--- /dev/null
+++ b/audio/clementine-player/files/patch-src-main.cpp
@@ -0,0 +1,12 @@
+--- src/main.cpp.orig 2013-08-05 07:51:55.259557059 +0000
++++ src/main.cpp 2013-08-05 08:02:30.142556079 +0000
+@@ -265,7 +265,9 @@
+ #endif
+
+ // This makes us show up nicely in gnome-volume-control
++#if !GLIB_CHECK_VERSION(2, 36, 0)
+ g_type_init();
++#endif
+ g_set_application_name(QCoreApplication::applicationName().toLocal8Bit());
+
+ RegisterMetaTypes();