aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-12-29 08:55:02 +0800
committerjgh <jgh@FreeBSD.org>2012-12-29 08:55:02 +0800
commit1b10e2df21fe43bcbbee657338bc777b5719d381 (patch)
tree34ed9bec62bcd1cb691a1395977c04ba886348bc
parente70f3228ee8b5613fb15ee1a71053f2cd155f38b (diff)
downloadfreebsd-ports-gnome-1b10e2df21fe43bcbbee657338bc777b5719d381.tar.gz
freebsd-ports-gnome-1b10e2df21fe43bcbbee657338bc777b5719d381.tar.zst
freebsd-ports-gnome-1b10e2df21fe43bcbbee657338bc777b5719d381.zip
- restore CFLAGS/LDFLAGS to not be hardcoded
Submitted by: maintainer, john@pcbsd.org
-rw-r--r--audio/pianobar/Makefile4
-rw-r--r--audio/pianobar/files/patch-Makefile16
2 files changed, 11 insertions, 9 deletions
diff --git a/audio/pianobar/Makefile b/audio/pianobar/Makefile
index 51f405aa5c77..163b98171c8f 100644
--- a/audio/pianobar/Makefile
+++ b/audio/pianobar/Makefile
@@ -26,7 +26,7 @@ PLIST_FILES= bin/pianobar
USE_BZIP2= yes
USE_GMAKE= yes
-CFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include -std=c99
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/audio/pianobar/files/patch-Makefile b/audio/pianobar/files/patch-Makefile
index 9a1034de83ae..913e6b330425 100644
--- a/audio/pianobar/files/patch-Makefile
+++ b/audio/pianobar/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2012-09-07 07:44:39.000000000 -0700
-+++ Makefile 2012-09-07 14:52:09.940335486 -0700
-@@ -4,7 +4,7 @@
+--- Makefile 2012-12-01 09:03:23.000000000 -0800
++++ Makefile 2012-12-28 15:03:03.150101419 -0800
+@@ -4,16 +4,14 @@
BINDIR:=${PREFIX}/bin
LIBDIR:=${PREFIX}/lib
INCDIR:=${PREFIX}/include
@@ -9,15 +9,17 @@
DYNLINK:=0
# Respect environment variables set by user; does not work with :=
-@@ -14,6 +14,7 @@
- ifeq (${CC},cc)
- CC=c99
+ ifeq (${CFLAGS},)
+ CFLAGS=-O2 -DNDEBUG
endif
+-ifeq (${CC},cc)
+- CC=c99
+-endif
+DEPCC=cc
PIANOBAR_DIR=src
PIANOBAR_SRC=\
-@@ -119,7 +120,7 @@
+@@ -119,7 +117,7 @@
# build dependency files
%.d: %.c
@set -e; rm -f $@; \