aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-11-21 07:53:22 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-11-21 07:53:22 +0800
commit1b88d9f974c07a7f58b73c0f6330ec5640ccbb3d (patch)
treeba58a1bcdaadbce4dca30f285ce8e61dbcf92edb
parent41665b8e9738de7f3b31814439a98d81a11a4844 (diff)
downloadfreebsd-ports-gnome-1b88d9f974c07a7f58b73c0f6330ec5640ccbb3d.tar.gz
freebsd-ports-gnome-1b88d9f974c07a7f58b73c0f6330ec5640ccbb3d.tar.zst
freebsd-ports-gnome-1b88d9f974c07a7f58b73c0f6330ec5640ccbb3d.zip
- Fix build for hosts without __cxa_thread_atexit
-rw-r--r--www/nghttp2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index b5ab1175d70f..478345a4f399 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -59,6 +59,13 @@ SPDY_LIB_DEPENDS= libspdylay.so:www/spdylay
CPPFLAGS+= -D_GLIBCXX_USE_C99
.endif
+# Disable thread_local support for hosts without __cxa_thread_atexit()
+# See PR/192320 for details
+.if (${OSVERSION} < 1003506) || ((${OSVERSION} >= 1100000) && (${OSVERSION} < 1100122)) || (${OSVERSION} == 1100500)
+post-configure:
+ @${REINPLACE_CMD} -e '/HAVE_THREAD_LOCAL/d' ${WRKSRC}/config.h
+.endif
+
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
CONFIGURE_ARGS+=--with-jemalloc
.endif