aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-04-28 20:16:33 +0800
committermarino <marino@FreeBSD.org>2015-04-28 20:16:33 +0800
commit1c6fb88306e5875406585a872ca47971f730f14d (patch)
tree79137c37e8f7e5999011330a2056ac60cb2eae3a
parent08a15f44aa31ff6b51e0ae076ad648e5353f5993 (diff)
downloadfreebsd-ports-gnome-1c6fb88306e5875406585a872ca47971f730f14d.tar.gz
freebsd-ports-gnome-1c6fb88306e5875406585a872ca47971f730f14d.tar.zst
freebsd-ports-gnome-1c6fb88306e5875406585a872ca47971f730f14d.zip
lang/gcc5-aux: r384038 (iconv commit) broken DragonFly, Fix
Swapping LIBS with LDFLAGS and removing the *_configargs definitions allows gcc5-aux to build on all supported platforms. Now that gcc5 has been released, new bootstrap compilers should be created for both FreeBSD and DragonFly in order remove bootstrapping requirement (previously gcc5 built live but not in poudriere, reason still unknown).
-rw-r--r--lang/gcc5-aux/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/lang/gcc5-aux/Makefile b/lang/gcc5-aux/Makefile
index 82fe94491e6c..d15d08fd4515 100644
--- a/lang/gcc5-aux/Makefile
+++ b/lang/gcc5-aux/Makefile
@@ -28,7 +28,7 @@ FULL_GNATGCC= NOT_SET
OS_LABEL4VERS= [${OPSYS}${GARCH:M*64:S/amd_//:S/x86_//}]
NO_MTREE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_GROUP= Standard Bootstrap
OPTIONS_GROUP_Standard= FORT OBJC NLS TESTSUITE STATIC
@@ -162,10 +162,7 @@ ADA_CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
ADA_CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
ADA_CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
ADA_CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
-ADA_CONFIGURE_ENV+= LIBS="${LIBS}"
ADA_CONFIGURE_ENV+= PATH=${FULL_PATH}
-ADA_CONFIGURE_ENV+= build_configargs="CPPFLAGS=\"${CPPFLAGS}\" LIBS=\"${LIBS}\""
-ADA_CONFIGURE_ENV+= host_configargs="CPPFLAGS=\"${CPPFLAGS}\" LIBS=\"${LIBS}\""
ADA_MAKE_ENV+= PATH=${FULL_PATH}
ADA_MAKE_ENV+= LD_LIBRARY_PATH=${BUILDDIR}/gcc