aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-07-26 07:28:26 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:14:34 +0800
commit1d48c9c4299916fc2f7fc66a4303fb054d458f64 (patch)
treeea79c4778c40a56fa013facc5f1e11dcbe7878e4
parentd6477f05383aeb5895e656ed2c2fd049d440edbd (diff)
downloadfreebsd-ports-gnome-1d48c9c4299916fc2f7fc66a4303fb054d458f64.tar.gz
freebsd-ports-gnome-1d48c9c4299916fc2f7fc66a4303fb054d458f64.tar.zst
freebsd-ports-gnome-1d48c9c4299916fc2f7fc66a4303fb054d458f64.zip
math/R: Fix build issues when LIBR option is off and fix runtime issue by
permitting FLANG only with RBLAS - Only apply SONAME patches when the relevant options are chosen. This prevents install errors when LIBR is off. - Only permit the FLANG option when RBLAS is chosen, because FLANG causes some configure-time checks to fail and the shared RBLAS library is fallen back upon, but not properly packaged, which causes runtime issues. - Bump PORTREVISION Reported by: rhurlin@gwdg.de Differential Revision: https://reviews.freebsd.org/D11726
-rw-r--r--math/R/Makefile6
-rw-r--r--math/R/files/extra-patch-src_extra_blas_Makefile.in (renamed from math/R/files/patch-src_extra_blas_Makefile.in)0
-rw-r--r--math/R/files/extra-patch-src_main_Makefile.in (renamed from math/R/files/patch-src_main_Makefile.in)0
-rw-r--r--math/R/files/extra-patch-src_modules_lapack_Makefile.in (renamed from math/R/files/patch-src_modules_lapack_Makefile.in)0
4 files changed, 5 insertions, 1 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 6644e538217a..e7bc939584b7 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -3,7 +3,7 @@
PORTNAME= R
PORTVERSION= 3.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math lang
MASTER_SITES= CRAN/src/base/R-${PORTVERSION:C|\..*||}
@@ -76,6 +76,7 @@ CAIROPANGO_CONFIGURE_WITH=cairo
CAIROPANGO_USES= gettext jpeg pkgconfig
CAIROPANGO_USE= GNOME=pango,cairo
FLANG_USE= binutils
+FLANG_PREVENTS= ATLAS OPENBLAS NETLIB
FLANG_BUILD_DEPENDS= flang:devel/flang
FLANG_RUN_DEPENDS= flang:devel/flang
FLANG_VARS= F77=flang FC=flang
@@ -96,6 +97,7 @@ JPEG_USES= jpeg
LDOUBLE_CONFIGURE_ENABLE=long-double
LETTER_CONFIGURE_ENV= R_PAPERSIZE=letter
LIBR_CONFIGURE_ENABLE= R-shlib
+LIBR_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src_main_Makefile.in
LTO_CONFIGURE_ENABLE= lto
LTO_CONFIGURE_ENV= AR="${LOCALBASE}/bin/gcc-ar${GCC_DEFAULT:S/.//g}" \
RANLIB="${LOCALBASE}/bin/gcc-ranlib${GCC_DEFAULT:S/.//g}"
@@ -121,6 +123,8 @@ RBLAS_CONFIGURE_ON= --without-blas \
--enable-BLAS-shlib
RBLAS_CONFIGURE_OFF= --with-blas="-L${LOCALBASE}/lib ${BLASLIB}" \
--with-lapack="${LAPACKLIB}"
+RBLAS_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src_extra_blas_Makefile.in \
+ ${PATCHDIR}/extra-patch-src_modules_lapack_Makefile.in
RPROF_CONFIGURE_ENABLE= R-profiling
TCLTK_IMPLIES= X11
TCLTK_USES= tcl tk:84+
diff --git a/math/R/files/patch-src_extra_blas_Makefile.in b/math/R/files/extra-patch-src_extra_blas_Makefile.in
index a2c5e19b4eed..a2c5e19b4eed 100644
--- a/math/R/files/patch-src_extra_blas_Makefile.in
+++ b/math/R/files/extra-patch-src_extra_blas_Makefile.in
diff --git a/math/R/files/patch-src_main_Makefile.in b/math/R/files/extra-patch-src_main_Makefile.in
index b922f8c88ff0..b922f8c88ff0 100644
--- a/math/R/files/patch-src_main_Makefile.in
+++ b/math/R/files/extra-patch-src_main_Makefile.in
diff --git a/math/R/files/patch-src_modules_lapack_Makefile.in b/math/R/files/extra-patch-src_modules_lapack_Makefile.in
index 73a9fcf1d2e2..73a9fcf1d2e2 100644
--- a/math/R/files/patch-src_modules_lapack_Makefile.in
+++ b/math/R/files/extra-patch-src_modules_lapack_Makefile.in