aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-06-29 21:15:26 +0800
committermm <mm@FreeBSD.org>2011-06-29 21:15:26 +0800
commit1e23c2cb5ef378238e27165d83ab68636eeb8340 (patch)
treeec60e3511b156d00389203abf71552abe45d5d02
parent565ae48f9939b5f1be11bc505fb1161bf4753c4a (diff)
downloadfreebsd-ports-gnome-1e23c2cb5ef378238e27165d83ab68636eeb8340.tar.gz
freebsd-ports-gnome-1e23c2cb5ef378238e27165d83ab68636eeb8340.tar.zst
freebsd-ports-gnome-1e23c2cb5ef378238e27165d83ab68636eeb8340.zip
Remove conditions with USE_GCC (not needed anymore)
-rw-r--r--graphics/opencv/Makefile17
1 files changed, 0 insertions, 17 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 979098916b98..51186f568f59 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -202,23 +202,6 @@ CMAKE_ARGS+= -DBUILD_TESTS:BOOL=Off \
.include <bsd.port.pre.mk>
-# This whole block looks a bit hackish, but it works...
-.if ${ARCH} == "amd64" && ${OSVERSION} < 700042
-USE_GCC= 4.2+
-.else
-CMAKE_OUTSOURCE= yes
-.if ${ARCH} == "i386" && ${OSVERSION} >= 700042 && ${OSVERSION} < 800107
-USE_GCC= 4.4+
-.endif
-.endif
-
-# Any other way to override CFLAGS and CXXFLAGS?
-.ifdef(USE_GCC)
-CMAKE_SOURCE_PATH= -DCMAKE_C_FLAGS:STRING="${CFLAGS:C/-Wl[^ ]*//g}" \
- -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS:C/-Wl[^ ]*//g}" \
- ${WRKSRC}
-.endif
-
post-patch:
@${MKDIR} ${CONFIGURE_WRKSRC}
@${REINPLACE_CMD} -e 's:set(OPENCV_SOVERSION.*:set(OPENCV_SOVERSION "$${OPENCV_VERSION_MAJOR}"):' \