aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-09-06 20:18:18 +0800
committertg <tg@FreeBSD.org>2000-09-06 20:18:18 +0800
commit1f0200e99086718a4741d75457a921976682463d (patch)
tree6fc2dc84dd447aeb0a6023bea3b02d4491a1fdec
parent25ce006ff896b9572c402de77c9f26c8a077e1f4 (diff)
downloadfreebsd-ports-gnome-1f0200e99086718a4741d75457a921976682463d.tar.gz
freebsd-ports-gnome-1f0200e99086718a4741d75457a921976682463d.tar.zst
freebsd-ports-gnome-1f0200e99086718a4741d75457a921976682463d.zip
Fix `python: command not found' when python doesn't exist.
Noticed by: steve
-rw-r--r--math/numpy/Makefile4
-rw-r--r--math/py-numeric/Makefile4
-rw-r--r--math/py-numeric17/Makefile4
-rw-r--r--misc/py-distutils/Makefile4
4 files changed, 9 insertions, 7 deletions
diff --git a/math/numpy/Makefile b/math/numpy/Makefile
index 142d5fe10eb6..b1ccbf97bb8c 100644
--- a/math/numpy/Makefile
+++ b/math/numpy/Makefile
@@ -26,8 +26,8 @@ PLIST_SUB= PYVERSION="python${PYVERSION}"
DOCDIR= ${PREFIX}/share/doc/py-numeric
EXAMPLEDIR= ${PREFIX}/share/examples/py-numeric
-PYVERSION!= python -c 'import string, sys; \
- print string.split(sys.version)[0][:3]' \
+PYVERSION!= (python -c 'import string, sys; \
+ print string.split(sys.version)[0][:3]') 2> /dev/null \
|| echo "1.5"
.if ${PYVERSION} == "2.0"
diff --git a/math/py-numeric/Makefile b/math/py-numeric/Makefile
index 142d5fe10eb6..b1ccbf97bb8c 100644
--- a/math/py-numeric/Makefile
+++ b/math/py-numeric/Makefile
@@ -26,8 +26,8 @@ PLIST_SUB= PYVERSION="python${PYVERSION}"
DOCDIR= ${PREFIX}/share/doc/py-numeric
EXAMPLEDIR= ${PREFIX}/share/examples/py-numeric
-PYVERSION!= python -c 'import string, sys; \
- print string.split(sys.version)[0][:3]' \
+PYVERSION!= (python -c 'import string, sys; \
+ print string.split(sys.version)[0][:3]') 2> /dev/null \
|| echo "1.5"
.if ${PYVERSION} == "2.0"
diff --git a/math/py-numeric17/Makefile b/math/py-numeric17/Makefile
index 142d5fe10eb6..b1ccbf97bb8c 100644
--- a/math/py-numeric17/Makefile
+++ b/math/py-numeric17/Makefile
@@ -26,8 +26,8 @@ PLIST_SUB= PYVERSION="python${PYVERSION}"
DOCDIR= ${PREFIX}/share/doc/py-numeric
EXAMPLEDIR= ${PREFIX}/share/examples/py-numeric
-PYVERSION!= python -c 'import string, sys; \
- print string.split(sys.version)[0][:3]' \
+PYVERSION!= (python -c 'import string, sys; \
+ print string.split(sys.version)[0][:3]') 2> /dev/null \
|| echo "1.5"
.if ${PYVERSION} == "2.0"
diff --git a/misc/py-distutils/Makefile b/misc/py-distutils/Makefile
index 35cf8746e43c..c72770de15dc 100644
--- a/misc/py-distutils/Makefile
+++ b/misc/py-distutils/Makefile
@@ -19,7 +19,9 @@ RUN_DEPENDS= python:${PORTSDIR}/lang/python
PLIST_SUB= PYVERSION="python${PYVERSION}"
-PYVERSION!= python -c 'import string, sys; print string.split(sys.version)[0][:3]' || echo "1.5"
+PYVERSION!= (python -c 'import string, sys; \
+ print string.split(sys.version)[0][:3]') 2> /dev/null \
+ || echo "1.5"
do-build:
@(cd ${WRKSRC}; python setup.py build)