aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2005-10-14 13:41:48 +0800
committerdinoex <dinoex@FreeBSD.org>2005-10-14 13:41:48 +0800
commit203fa6d77ab0d9a3ae7cb91bb40ab1aee49898c0 (patch)
tree1c8dcc63211972fa6b7884938af18dd7b02cc572
parent1e28ba543fe41dc826707e0d94a5bf379b874546 (diff)
downloadfreebsd-ports-gnome-203fa6d77ab0d9a3ae7cb91bb40ab1aee49898c0.tar.gz
freebsd-ports-gnome-203fa6d77ab0d9a3ae7cb91bb40ab1aee49898c0.tar.zst
freebsd-ports-gnome-203fa6d77ab0d9a3ae7cb91bb40ab1aee49898c0.zip
- binary compatability patch
PR: 87419 Submitted by: Phil Oleson
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files/patch-evp.h14
-rw-r--r--security/openssl/files/patch-hmac.h14
3 files changed, 29 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index f17ba6c31da5..4c18ebdff46e 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -12,7 +12,7 @@ PORTREVISION!= date -v-1d +%Y%m%d
.else
.if !defined(WITH_OPENSSL_BETA) && defined(WITH_OPENSSL_097)
PORTVERSION= 0.9.7h
-PORTREVISION?= 0
+PORTREVISION?= 1
.else
PORTVERSION= 0.9.8a
PORTREVISION?= 0
diff --git a/security/openssl/files/patch-evp.h b/security/openssl/files/patch-evp.h
new file mode 100644
index 000000000000..dabadea299e4
--- /dev/null
+++ b/security/openssl/files/patch-evp.h
@@ -0,0 +1,14 @@
+--- crypto/evp/evp.h.orig Thu Oct 13 17:24:41 2005
++++ crypto/evp/evp.h Thu Oct 13 17:26:32 2005
+@@ -132,7 +132,11 @@
+ #define EVP_CAST5_KEY_SIZE 16
+ #define EVP_RC5_32_12_16_KEY_SIZE 16
+ */
++#ifdef OPENSSL_FIPS
+ #define EVP_MAX_MD_SIZE 64 /* longest known SHA512 */
++#else
++#define EVP_MAX_MD_SIZE (16+20) /* The SSLv3 md5+sha1 type */
++#endif
+ #define EVP_MAX_KEY_LENGTH 32
+ #define EVP_MAX_IV_LENGTH 16
+ #define EVP_MAX_BLOCK_LENGTH 32
diff --git a/security/openssl/files/patch-hmac.h b/security/openssl/files/patch-hmac.h
new file mode 100644
index 000000000000..dab469e67b67
--- /dev/null
+++ b/security/openssl/files/patch-hmac.h
@@ -0,0 +1,14 @@
+--- crypto/hmac/hmac.h.orig Thu Oct 13 17:27:32 2005
++++ crypto/hmac/hmac.h Thu Oct 13 17:28:43 2005
+@@ -64,7 +64,11 @@
+
+ #include <openssl/evp.h>
+
++#ifdef OPENSSL_FIPS
+ #define HMAC_MAX_MD_CBLOCK 128
++#else
++#define HMAC_MAX_MD_CBLOCK 64
++#endif
+
+ #ifdef __cplusplus
+ extern "C" {