aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-10-15 19:45:50 +0800
committersem <sem@FreeBSD.org>2005-10-15 19:45:50 +0800
commit20f459e5906b7c1e2e2b0e835b1dda7d6a253c1b (patch)
treea6468b6749b42ce94040078d75e34b6978d90e75
parent93fb9485c606058a25b44936994a366c07775984 (diff)
downloadfreebsd-ports-gnome-20f459e5906b7c1e2e2b0e835b1dda7d6a253c1b.tar.gz
freebsd-ports-gnome-20f459e5906b7c1e2e2b0e835b1dda7d6a253c1b.tar.zst
freebsd-ports-gnome-20f459e5906b7c1e2e2b0e835b1dda7d6a253c1b.zip
- Add a knob to turn off IPv6 support
- Fix compilation problem with check_snmp on 4.x - Reset maintainer PR: ports/86972 Offered by: Alex Samorukov <samm@os2.kiev.ua> Submitted by: Blaz Zupan <blaz@si.FreeBSD.org> (maintainer)
-rw-r--r--net-mgmt/nagios-plugins/Makefile12
-rw-r--r--net-mgmt/nagios-plugins/files/patch-check_snmp.c18
2 files changed, 28 insertions, 2 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 45d20587c5af..0ba5d3f01744 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -7,12 +7,13 @@
PORTNAME= nagios-plugins
PORTVERSION= 1.4.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= nagiosplug
-MAINTAINER= blaz@si.FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Plugins for nagios
OPTIONS= QSTAT "Game server query support" off \
@@ -21,7 +22,8 @@ OPTIONS= QSTAT "Game server query support" off \
RADIUS "Radius support" off \
MYSQL "MySQL support" off \
PGSQL "PostgreSQL support" off \
- LDAP "OpenLDAP support" off
+ LDAP "OpenLDAP support" off \
+ IPV6 "IPV6 support" on
.include <bsd.port.pre.mk>
@@ -43,6 +45,12 @@ PLIST_SUB+= SUB_QSTAT=""
PLIST_SUB+= SUB_QSTAT="@comment "
.endif
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+=--with-ipv6
+.else
+CONFIGURE_ARGS+=--without-ipv6
+.endif
+
.if defined(WITH_FPING)
BUILD_DEPENDS+= fping:${PORTSDIR}/net/fping
RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
diff --git a/net-mgmt/nagios-plugins/files/patch-check_snmp.c b/net-mgmt/nagios-plugins/files/patch-check_snmp.c
new file mode 100644
index 000000000000..a0638831ed4d
--- /dev/null
+++ b/net-mgmt/nagios-plugins/files/patch-check_snmp.c
@@ -0,0 +1,18 @@
+--- plugins/check_snmp.c.orig Sat Oct 15 09:41:06 2005
++++ plugins/check_snmp.c Sat Oct 15 09:48:43 2005
+@@ -206,6 +206,7 @@
+ strcat(perfstr, "| ");
+ while (ptr) {
+ char *foo;
++ char *str[MAX_INPUT_BUFFER];
+
+ foo = strstr (ptr, delimiter);
+ strncat(perfstr, ptr, foo-ptr);
+@@ -338,7 +339,6 @@
+
+ i++;
+
+- char *str[MAX_INPUT_BUFFER];
+ asprintf(str, "=%s%s;;;; ", show, type ? type : "");
+ strcat(perfstr, *str);
+