aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 02:54:15 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 02:54:15 +0800
commit2103b6f92937b25a12e887110ff5e82f8ec5f590 (patch)
tree09ed84cde68ef180ff88ac47bdc5ff35750cef5f
parent63b7bb8a97ca5017d27fa777ff843f188ce7b0e1 (diff)
downloadfreebsd-ports-gnome-2103b6f92937b25a12e887110ff5e82f8ec5f590.tar.gz
freebsd-ports-gnome-2103b6f92937b25a12e887110ff5e82f8ec5f590.tar.zst
freebsd-ports-gnome-2103b6f92937b25a12e887110ff5e82f8ec5f590.zip
Anaphoric and miscellaneous useful control-flow.
WWW: http://hackage.haskell.org/package/IfElse Obtained from: FreeBSD Haskell
-rw-r--r--devel/hs-IfElse/Makefile22
-rw-r--r--devel/hs-IfElse/distinfo2
-rw-r--r--devel/hs-IfElse/pkg-descr3
-rw-r--r--lang/ghc/bsd.hackage.mk1
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/hs-IfElse/Makefile b/devel/hs-IfElse/Makefile
new file mode 100644
index 000000000000..d8adc8824dcc
--- /dev/null
+++ b/devel/hs-IfElse/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-IfElse
+# Date created: April 7, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= IfElse
+PORTVERSION= 0.85
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Anaphoric and miscellaneous useful control-flow
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= mtl
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-IfElse/distinfo b/devel/hs-IfElse/distinfo
new file mode 100644
index 000000000000..102e361d482b
--- /dev/null
+++ b/devel/hs-IfElse/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/IfElse-0.85.tar.gz) = 8ad3bfc3e2c867e6330d9bff874b3105476c35b2e1638fd448f233e9f80addcd
+SIZE (cabal/IfElse-0.85.tar.gz) = 2865
diff --git a/devel/hs-IfElse/pkg-descr b/devel/hs-IfElse/pkg-descr
new file mode 100644
index 000000000000..1a2d3ebb2981
--- /dev/null
+++ b/devel/hs-IfElse/pkg-descr
@@ -0,0 +1,3 @@
+Anaphoric and miscellaneous useful control-flow.
+
+WWW: http://hackage.haskell.org/package/IfElse
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 730a8cefd917..2f392d87c96e 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -154,6 +154,7 @@ hxt_port= textproc/hs-hxt
hxt-charproperties_port= textproc/hs-hxt-charproperties
hxt-regex-xmlschema_port= textproc/hs-hxt-regex-xmlschema
hxt-unicode_port= textproc/hs-hxt-unicode
+IfElse_port= devel/hs-IfElse
IORefCAS_port= devel/hs-IORefCAS
json_port= converters/hs-json
language-c_port= devel/hs-language-c