aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-11-18 23:20:34 +0800
committermnag <mnag@FreeBSD.org>2005-11-18 23:20:34 +0800
commit213c311e38847d3e6dfce2391ef576f966d1d1f8 (patch)
tree8b615cd9577750ac47ebfad6171ebef65f2809bd
parent23c56f582dceb6b9fccab7e0070b0afe0606abe6 (diff)
downloadfreebsd-ports-gnome-213c311e38847d3e6dfce2391ef576f966d1d1f8.tar.gz
freebsd-ports-gnome-213c311e38847d3e6dfce2391ef576f966d1d1f8.tar.zst
freebsd-ports-gnome-213c311e38847d3e6dfce2391ef576f966d1d1f8.zip
Backport devel patch to fix underflow in in modify_shared_string()
Bump PORTREVISION PR: 89225 Submitted by: Xavier Beaudouin <kiwi@oav.net> (maintainer)
-rw-r--r--lang/pike76/Makefile1
-rw-r--r--lang/pike76/files/patch-stralloc.c28
2 files changed, 29 insertions, 0 deletions
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index 0ace3b3847bf..a3fb87259e41 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pike76
PORTVERSION= 7.6.50
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
ftp://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
diff --git a/lang/pike76/files/patch-stralloc.c b/lang/pike76/files/patch-stralloc.c
new file mode 100644
index 000000000000..50c28ad6bd4e
--- /dev/null
+++ b/lang/pike76/files/patch-stralloc.c
@@ -0,0 +1,28 @@
+--- src/stralloc.c.old Fri Nov 18 11:06:05 2005
++++ src/stralloc.c Fri Nov 18 11:06:10 2005
+@@ -2,7 +2,7 @@
+ || This file is part of Pike. For copyright information see COPYRIGHT.
+ || Pike is distributed under GPL, LGPL and MPL. See the file COPYING
+ || for more information.
+-|| $Id: stralloc.c,v 1.169 2005/01/19 13:06:57 grubba Exp $
++|| $Id: stralloc.c,v 1.170 2005/11/18 01:14:22 nilsson Exp $
+ */
+
+ #include "global.h"
+@@ -24,7 +24,7 @@
+ #include <ctype.h>
+ #include <math.h>
+
+-RCSID("$Id: stralloc.c,v 1.169 2005/01/19 13:06:57 grubba Exp $");
++RCSID("$Id: stralloc.c,v 1.170 2005/11/18 01:14:22 nilsson Exp $");
+
+ /* #define STRALLOC_USE_PRIMES */
+
+@@ -1596,6 +1596,7 @@
+ add_ref(a = old);
+ } else {
+ link_pike_string(a, a->hval);
++ add_ref(a);
+ }
+ return a;
+ }else{