aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2013-01-29 09:18:45 +0800
committerjkim <jkim@FreeBSD.org>2013-01-29 09:18:45 +0800
commit214d3298aab4f45b736b96d5bdab29a82bbd5567 (patch)
tree0fff63924c9246ece75805350a1a548f84a8743c
parent21d47052aacb7dbfde3dc313e335ec486f6b4d80 (diff)
downloadfreebsd-ports-gnome-214d3298aab4f45b736b96d5bdab29a82bbd5567.tar.gz
freebsd-ports-gnome-214d3298aab4f45b736b96d5bdab29a82bbd5567.tar.zst
freebsd-ports-gnome-214d3298aab4f45b736b96d5bdab29a82bbd5567.zip
- Use SOURCEWARE master sites.
- Use make for regression test. - Tidy up and make portlint happy.
-rw-r--r--devel/libffi/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/libffi/Makefile b/devel/libffi/Makefile
index 87baf15943ad..ab47437c860f 100644
--- a/devel/libffi/Makefile
+++ b/devel/libffi/Makefile
@@ -4,8 +4,8 @@
PORTNAME= libffi
PORTVERSION= 3.0.11
CATEGORIES= devel
-MASTER_SITES= ftp://sourceware.org/pub/libffi/ \
- http://www.mirrorservice.org/sites/sourceware.org/pub/libffi/
+MASTER_SITES= SOURCEWARE
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Foreign Function Interface
@@ -16,7 +16,7 @@ TEST_DESC= Run regression test suite
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTEST}
-BUILD_DEPENDS= runtest:${PORTSDIR}/misc/dejagnu
+BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
GNU_CONFIGURE= yes
@@ -31,11 +31,13 @@ MAN3= ffi.3 ffi_call.3 ffi_prep_cif.3 ffi_prep_cif_var.3
.if ${PORT_OPTIONS:MTEST}
post-build:
- @cd ${WRKSRC} && ${GMAKE} check
+ @cd ${WRKSRC} && ${MAKE} check
.endif
post-install:
- @${LN} -sf ../lib/libffi-${PORTVERSION}/include/ffi.h ${PREFIX}/include/
- @${LN} -sf ../lib/libffi-${PORTVERSION}/include/ffitarget.h ${PREFIX}/include/
+ @${LN} -sf ../lib/libffi-${PORTVERSION}/include/ffi.h \
+ ${PREFIX}/include/
+ @${LN} -sf ../lib/libffi-${PORTVERSION}/include/ffitarget.h \
+ ${PREFIX}/include/
.include <bsd.port.mk>