aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-05 04:09:01 +0800
committerbapt <bapt@FreeBSD.org>2013-05-05 04:09:01 +0800
commit21652b4dea71ed4731155252a2bd492102ff7003 (patch)
tree71b940e987231ce033355bca877c126d84bb7584
parentf14531ebc7b490eac16e65a52b2564624871e548 (diff)
downloadfreebsd-ports-gnome-21652b4dea71ed4731155252a2bd492102ff7003.tar.gz
freebsd-ports-gnome-21652b4dea71ed4731155252a2bd492102ff7003.tar.zst
freebsd-ports-gnome-21652b4dea71ed4731155252a2bd492102ff7003.zip
Fix build with bmake, convert to new options framework
-rw-r--r--devel/libghthash/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/devel/libghthash/Makefile b/devel/libghthash/Makefile
index f7b681ee6043..42e1438fbcb2 100644
--- a/devel/libghthash/Makefile
+++ b/devel/libghthash/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: libghthash
-# Date created: Jul 2, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= libghthash
PORTVERSION= 0.6.2
@@ -23,6 +18,10 @@ PLIST_FILES= include/ght_hash_table.h \
lib/libghthash.a lib/libghthash.la \
lib/libghthash.so lib/libghthash.so.2
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
+
MAN3= ght_create.3 \
ght_finalize.3 \
ght_first.3 \
@@ -36,12 +35,14 @@ MAN3= ght_create.3 \
PORTDOCS= *
PORTEXAMPLES= *
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC}/html && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \*.c ${EXAMPLESDIR})
.endif