aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlx <lx@FreeBSD.org>2010-02-23 06:16:40 +0800
committerlx <lx@FreeBSD.org>2010-02-23 06:16:40 +0800
commit21e228cff72060226e4c549ca3bf6a588b8d61f5 (patch)
tree043603866351eaaadc0f320271c479396d39ced7
parent422c53727ebed58a575cec73c310f7e18a67d31b (diff)
downloadfreebsd-ports-gnome-21e228cff72060226e4c549ca3bf6a588b8d61f5.tar.gz
freebsd-ports-gnome-21e228cff72060226e4c549ca3bf6a588b8d61f5.tar.zst
freebsd-ports-gnome-21e228cff72060226e4c549ca3bf6a588b8d61f5.zip
Update to use DESKTOP_ENTRIES and OPTIONS.
PR: ports/144216 Submitted by: Max Brazhnikov <makc@FreeBSD.org> Feature safe: yes
-rw-r--r--games/gltron/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/games/gltron/Makefile b/games/gltron/Makefile
index f2ac920084fc..b6350ce881de 100644
--- a/games/gltron/Makefile
+++ b/games/gltron/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gltron
PORTVERSION= 0.70
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION}
EXTRACT_SUFX= -source.tar.gz
@@ -27,6 +27,17 @@ CONFIGURE_ARGS= --disable-warn
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+OPTIONS= SDL_NET "With network support" off
+
+DESKTOP_ENTRIES= "GLtron" \
+ "3D lightcycle game" \
+ "${DATADIR}/art/default/gltron.png" \
+ "gltron" \
+ "Game;ArcadeGame;" \
+ false
+
+.include <bsd.port.options.mk>
+
.if defined(WITH_SDL_NET)
USE_SDL+= net
CONFIGURE_ARGS+= --enable-network